DFU Help - There HAS to be an easy way [SOLVED]

Ok Two topics here:

  1. I know there is simple web based option to perform DFU with an electron. Its the same thing you do when you first setup your electron. In fact someone here on this forum once linked it to me. I have searched and searched and cannot find that link or the related thread however. All I have been able to find from going through the documentation is a link to this:
    http://blog.jongallant.com/2015/08/particle-photon-firmware-flash-windows/

That insanely complex and round-about method cannot possibly be the only way to perform a dfu update now available can it? I just need to perform a simple DFU update.

  1. The reason I need to perform a DFU update is I forgot the Particle Dev program only compiles to the newest deep firmware release. I flashed some code to a device that does not have the latest deep firmware and now it will only blink red with a hard fault error code (the device will NOT go into safe mode). However, it will go into DFU update mode so I hope I can salvage the device that way.

If you’ve got the CLI set up properly (which is extremely advisable, especially when using Electrons) it’s as easy as placing your device in DFU mode, and issuing Particle flash --usb firmware.bin.

2 Likes

Thanks Moors7. I tried that. It looks like it would have worked except that it does not detect any device in DFU mode even though my device is blinking yellow :frowning:

What OS are you on?
If Windows, have you installed the correct drivers?
Does you computer see the device at all?

Win 10. I just updated the CLI to see if that would help, no change. I have flashed this device hundreds of times on the same setup. I get the windows “USB sound” when the device starts blinking yellow so Windows appears to recognize it on the SUB port. But can’t flash. The fact that it will not go into safe mode makes me think maybe its a hardware failure that was brought on by my last flash attempt? Its odd, the device will start to flash magenta when I have the mode button held down (after pressing mode and reset at the same time) but as soon as I let up off the mode button it goes right back to flashing red instead of continuing into safe mode. :frowning:

In DFU Mode?

What’s that?
You should use zadig (as shown in your link) or the CLI Windows installer to get the DFU drivers installed correctly.

In DFU Mode?
Good point, no never in DFU mode.

SUB port.
Sorry, USB port.

Trying the steps on the link now. But I tought the following step would make sense as I went through it, it does not :frowning:

“Add the win32-mingw32 folder to your PATH environment variable.”

Not sure what is meant by that.

How to edit your PATH:

I was only refering to the zadig part to install DFU drivers of that link.
The rest is not required with CLI.

1 Like

SirT, I appear to be in a very similar position. Same thing happens trying to enter safe mode. DFU blinks yellow, but can’t flash over USB

@doughtz, since you are in a very similar position, the suggestions above apply just as similarly :wink:

1 Like

Thanks @ScruffR and all!!

I was only refering to the zadig part to install DFU drivers of that link.
The rest is not required with CLI.

I added the driver with zadig and that worked.
Since I already had CLI, I then used “particle update” and that worked as well.
I was then able to go into safe mode, then listen mode, and get tinker working :smile:

3 Likes