USB Connection Problem on Particle Device


#1

Hello,
I am using Particle photon and P1. a very first time after installing Particle CLI windows installer. it was restarting my PC with Blue screen when i attempt to connect PHOTON using USB. i have uninstalled everything regarding particle still it was same. then i have tried on Another pc. this time what i did i installed driver for photon first acc to procedure given here then i installed Particle CLI then it was working good. now i want to connect P1 then i followed same procedure as given in above link to install P1 driver. and it again started restarting with blue screen. Photon is working good. but it have problem with P1. any can guide me to problem/ solution? am i missing something?


#2

What operating system on your PC?


#3

Windows 7


#4

The Photon and P1 use the same Windows serial device driver. However that post has an old version of the serial driver that is not recommended. You should follow the instructions here to remove the old serial driver and install the correct one.


#6

i followed same procedures i got photon working good but for P1 i have this problem.


#7

@tejasvini The steps you linked to are outdated and no driver is required for the latest Windows 10.

This installer will clean up old drivers and install a combined driver though if you’d like to try it:
https://github.com/particle-iot/windows-device-drivers/releases/tag/v6.1.0.68

On a clean install though, you shouldn’t need to install any particle drivers for Windows 10.


#8

OP has stated


#9

In that case, the driver I linked to is the way to go :slight_smile:


#10

Hello,
@BDub @ScruffR @rickkas7 @ninjatill
everyone many thanks for your quick reply. now i have solved driver problem of P1. after that port appear in device manager i tried to connect in particle desktop IDE. it connected well. and was showing log also working. but after few hours new problem arose. port was showing in device manager but i was not able to connect in particle IDE even terminal and putty also not showing port when i rescan at same time it shows port in device manager. this only happens in P1. Photon is working good. can anyone help me?


#11

@tejasvini, you mention problems with the P1.

Q1. Is the P1 on ”homegrown” hardware?

Q2. Has the USB worked with any other host, eg Mac or Linux?

I ask because you could have a hardware problem!


#12

@UMD, I have not tried with other host. but with setup i am using its running well (Showing message on serial) for 5-10 min. after reset then it stop displaying when i check for port in terminal after stop on serial it does not show port in available ports at that time that port is available in device manager .


#13

One thing with Windows is that you have to close the port before the device comes back otherwise Windows will recognise it as new device and consequently assign a new port and maybe even pick a new driver for it.
That’s a typical Windows flaw.

Try out particle serial monitor --follow which should be able to deal with that situation.

Another thing I have found with Windows and some terminal programs is that you only get new data coming in after you sent at least one byte to the device - the reason for that is the way how these terminals are treating the virtual RTS/DTR “lines”.
After an unexpected disconnect the state of these lines may prevent communication.


#14

@tejasvini, with @scruffr’s description of Windows behaviour it should be case closed.

Don’t forget to mark his comment as a solution if you believe it to be.


#15

All of your suggestions was very helpful. but some of my limitation i do not want to use particle CLI. so i don’t know

Try out particle serial monitor --follow which should be able to deal with that situation.

will work or not. right now for me Putty is working good. what i made changes. i also used Serial1 which is on PA9 PA10 pins. whose flow conntrol pins are on same USB pins. it could be interfering so i used UART1 with None flow control. and its working good.