Having issue with particle p1

Hi everyone! i have visited this forum for a while now and its time to ask my first question :).

after working for a while with the photon i was trying to work with the p1 (connected to pcb).
the problem i get is when i first tried to connect to the p1 i was able to see it in my wifi connections (on my leptop and my phone).
i entered the ssid and the wifi pass (via the web connection) and the second i did it the p1 disappeard from my wifi connection list and i was not able to claim it or do nothing else with it.
i have tried to unplug it and pluged it again (tried reset as well) and i still cant see it on my wifi connections.
i got the same problems with 2 different p1’s and got the same problem with both of them.

anyone has an idea of what can cause this problem?

Is the P1 in listening mode?

i have no led lights or buttons on it, so i dont really know if its in listening mode.
i know it was at first becuase i did saw it on my wifi list, i have no clude what mode it was on afterwards.
(i reset it as well with the RST pin but still no change).

thank you for the reply.

Do you have USB access? If so you could do all this on a computer with particle-cli.

i have no usb connection… only the chip with the wifi.

You should definitely try to get a USB connection.

im afraid i cannot use the usb connection at all…
is there another solution without the usb connection?

thanks for the answer!

That would be the expected behavior. You only go into listening mode (blinking dark blue, if you had an LED) if you don’t have Wi-Fi credentials. Once you have credentials, you’ll go into operational mode and the SoftAP configuration Wi-Fi is no longer available so it won’t appear in the apps or anywhere.

We strongly recommend including on a P1 board:

  • Mode and reset buttons
  • USB
  • SWD pins (D7, D6, 3V3, and GND)
  • TX and RX (optional)

You can put them on a debug connector/daughter card if you want, but not having them at all makes it nearly impossible to troubleshoot the device.


thank you very much for the answer!
we will try to implement your tips and hopefully fix this issue.
thanks again! :slight_smile: