Unable to unbrick my Photon via USB

I’ve been trying to get Nuttx installed on my Photon and I inadvertently bricked it. I flashed it with sudo dfu-util -d 2b04:d006 -a 0 -s 0x08020000 -D nuttx.bin while it was in DFU mode, but it just kept blinking yellow, even though it said it was sucessful. My laptop ended up freezing and I ended up pulling the power on the Photon while it was in DFU mode. I turned my laptop back on and I got the same results. It would just continue to blink yellow. At this point I gave up trying to flash it with Nuttx and just wanted to reset it. So, I put the device in DFU mode and tried to put Tinker on it with particle flash --usb tinker. The particle program said it was flashed successfully, but then the status LED goes blank, the D7 led isn’t on either. If I disconnect the device the device and plug it back in none of the LEDs will turn back on, but I can still put the device in DFU mode and get the same result as before. I’m not sure what exactly to do. I’m thinking of possibly using my Bus Pirate to reset the Photon via JTAG, but I’m not what specific steps are required. If there’s an easier option or something I’m missing I’d love to hear it. Yeah, so… I’m stuck and I’d really appreciate any help or suggestions.

Hi, would you like to try the restore tool? Not sure if it would help though:


That worked perfectly. Thank you so much. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.