Unable to Pair Photon with Tinker App

I had once successfully paired Photon with tinker app (ios). Then i released the device and trying to pair it again with another account.
When i try to pair again, connect to Photon wifi, enter wifi credential, it first start blinking GREEN and the starts a sequence of CYAN and 3 Orange(Yellow,Red mixed) light.
I tried a lot but cannot pair it again.

Suggestions will be helpful.

It’s most likely an issue with the keys. There’s a guide in the docs on how to deal with that in the troubleshooting section if I’m not mistaken.
Also, searching for “orange” on the forum will give you more hits than needed to solve this :smile:
Have a look and let us know if you need further help.

At first i claimed the device smoothly and it worked, then i unclaimed it.

Now i am trying to reclaim it but could not do it, i have searched on the community questions bt cannot find suitable solution.

  • When i try to claim it from IOS app, it goes good at start but at last step of verification, give error.
  • It blinks like " cyan then 3 times orange then green in cycle"
  • I tried to claim device from cli, but it said device is not connected to wifi, i tried to connect it to wifi, it siad “Done! Your device should now restart”, but nothing happens, it blinked 3 time orange, then continues to blink cyan.
  • I cannot enter in safe mode, (blinks white and then green, and then pattern of cyan and orange).

How can i get it working?


I have tried following steps for key issue:
1.) connect your device, and place it into Listening mode (flashing blue), type particle identify to get the device id.
2.) reset your core and place it into DFU Mode
3.) type particlekeys doctor your_device_id
4.) then type particle keys send [your_device_id] [your_new_key_file.pub.pem]

At the end the key was submitted successfully, then the device restarted, but still i am having orange blinks followed by Cyan…

I also followed steps in [SOLVED]Photon fast blinking cyan (with a random red burst)
but same error…

then i tried this:
Download the server public key from https://s3.amazonaws.com/spark-website/cloud_public.der101
CMD>> dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

What should i try more ?


Not sure if it solves the issue, but it definitely doesn’t hurt: could you try upgrading your CLI to the latest version using npm upgrade -g particle-cli, then put your photon in DFU mode and do particle update. That should get your photon on the latest released version of firmware, which may, or may not, help solve some connectivity issues.
See if that helps, and if not, report back.

I tried it but is not solved. Previously it stopped giving 3 blinks of orange, but now started again …

Ok, so now it is blinking Cyan constantly… Mean connected to Wifi but unable to reach cloud…
i tried the command>> particle keys server cloud_public.der
but nothing happened…
I unplugged the device, plugged in again… Started flashing Green, Orange cycles, then green, Cyan Orange cycles…then only Cyan Orange… and after 2,3 minutes continued Cyan blinking…