Photon can't claim


#1

After removing my device from the IDE, updating the firmware (particle_firmware_manager-v0.5.2b-windows), doing a particle update and finally using my iPhone to claim my photon, I get the error message below:

My photon is blinking cyan. Device ID = 1c0029001047353138383138. It shows up in the particle serial list as a Photon and COM5:

Any thoughts?


#2

Can you do a particle device add 1c0029001047353138383138 on your CLI? Make sure the Photon is connected to the internet


#3

I think that’s part of the problem, it blinking cyan as aposed to breathing cyan. It’s not connecting to my OPEN WiFi. I have two other Photons on the same WiFi SSID and they are working right now just fine.

Also noticed after I did a particle flash tinker that every few beats of the blinking cyan I see a flash of red.


#4

When I try to do a particle serial identify I get the error message shown below: I’ve reboot my machine and reconnected my Photon. I have other Photons that work great.

If I open COM5 with PuTTY and type I,V, M and W. I get the following output"

Finally, here’s the blinking of the status LED:


#5

The red blinks indicates that the Photon is unable to connect to internet.

Can you try with another hotspot?


#6

Its breathing Cyan now. Here’s what I did to get it to that point.

particle keys new

Then put the device in DFU mode and flash this new key

dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der

Download the server public key from https://s3.amazonaws.com/spark-website/cloud_public.der292

dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

particle keys load device.der
particle keys send 1c0029001047353138383138 device.pub.pem

particle device add 1c0029001047353138383138


#7

Can you get the device ID and do a particle keys doctor paste-device-id-here


#8

Its working now, see my reply before this one for all the details.

Thanks for your help! I really appreciate it!


#9

Just for future drivers by:
The easier first shot for that issue would be

particle keys doctor <insertYourDeviceID>
particle keys server

Only doctor might be not sufficient and the other way (pluse some extra settings) only needs to be used if that doesn’t work.


#10

Thanks for noting the easier way, I hope I don’t need it in the future, but someone else might and two lines is much better than the 6 of mine.


#11

Also easier to memorize - I can’t even keep the VID:PID combo apart for the three Particle devices, let alone the memory locations :blush:


#12

Very true, the mind can only do so much!

Thanks again to everyone for your help (and patience)!


#13

I,am now facing same problem , It’s stuck on the Verifying product ownership ,I tried to claim the device using the build.particle.io but it’s throw a error Could not claim device..
i got the device id using PuTTY device id :-180032000847343432313031


#14

The normal sequence on the status LED is: white, blinking green, blinking cyan (light blue), fast blinking cyan, and finally breathing cyan.

How far along the process do you get?


Breathing cyan

If you get all the way to breathing cyan, you can just claim manually using one of these techniques:

Breathing cyan - Method 1

If you have not done so already, please install the Particle CLI. The command line utilities are useful not only for solving this problem but will be valuable later on, as well.

https://docs.particle.io/guide/tools-and-features/cli

If you are using Windows, be sure to use the link to Windows CLI Installer that will automatically install all of the components instead of the more complicated manual install.

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue. Then issue the CLI command:

particle serial identify

Save the Device ID; you’ll need it next.

Reset the Photon and wait for it to breathe cyan. The next step won’t succeed until it’s breathing cyan. Then issue the command:

particle device add YOUR_DEVICE_ID

Breathing cyan - Method 2

If you don’t want to install the CLI now, you can use one of the techniques in this document for finding your device ID:

https://docs.particle.io/faq/particle-devices/finding-device-id/photon/

Once you know it, you can go to https://build.particle.io. Select the Devices icon (circle with 4 lines) and use the Add Device link to add the device. The Photon must be in breathing cyan mode and then use the Device ID you obtained earlier and enter it into the box.


Blinking green

If you only get to blinking green your Photon is unable to connect to Wi-Fi.

First, a few known working situations that the Photon is not compatible with:

  • If you are using a corporate or school network that uses WPA2 Enterprise, the Photon cannot be used at this time. If you require both a username and a password, or see a mention of 802.1(x), or RADIUS you’re using WPA2 Enterprise.

  • If you are using a network that takes you to a web page where you need to either sign in or agree to terms and service when you first connect, using the Photon directly will be difficult or impossible. This is the case in some hotels and public Wi-Fi networks and is often referred to as Captive Portal.

  • If your Wi-Fi network uses 5 GHz only, instead of the more common 2.4 GHz, the Photon cannot be used. The Wi-Fi radio is only compatible with 2.4 GHz networks.

For home users:

  • If your router uses WEP encryption, you should upgrade your router to something more secure. However it may be possible to connect your Photon with some difficulty by following the WEP configuration instructions.

And the less common situations there are additional tips here.


Fast blinking cyan with red or orange blinks

If you get to fast blinking cyan, with red or orange blinks before going back to blinking green or blinking cyan, you may have corrupted device keys.

You’ll need to have the Particle Command Line Interface (CLI) installed, so if you have not installed it yet, follow the instructions here:

https://docs.particle.io/guide/tools-and-features/cli/photon/

if you are using Windows, make sure you use the Windows CLI Installer link and skip the other steps.

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue. Then issue the CLI command:

particle serial identify

Save the Device ID; you’ll need it later.

Then put the Photon in DFU mode by holding down both the RESET and SETUP buttons, releasing RESET and continuing to hold down SETUP until it blinks yellow and issue the commands below, in order.

particle keys server
particle keys doctor YOUR_DEVICE_ID

If you get this error under Windows:

'openssl' is not recognized as an internal or external command, operable program or batch file.

and you have used the CLI installer as described above, it may work if you do:

cd c:\OpenSSL-Win32\bin
particle keys doctor YOUR_DEVICE_ID

There are additional tips for a missing openssl error on this page, including tips for Mac OS X and Linux.


#15

@rickkas7 Thanks for the fast and detailed message , The problem with the wifi ,after i tried to connect with a another wifi , it’s working fine .