Unable to add devices back in devices list after delete

core
Tags: #<Tag:0x00007fe21dec9f08>

#1

I removed my device from the Web IDE. But now I am unable to put it back.

Access Toke in webIDE has the message that the token cant be used because its not active.

Also I have tried to use CLI to get device ID and list. I get device ID but there is not device returned from list command.

How do I add my device back? Can anyone throw some light here? Unable to connect to WiFI as well (LEDs are not breathing Cyan)


#2

You can create a new (active) access token in Web IDE.

More telling would be to know what the RGB LED is doing tho’


#3

It gives me message that the access token cant be used till i activate. can you please be more specific on the procedure?
LEDs are blinking green continuously for some time and then goes to cyan and then comes back again to blinking green


#4

Not sure where the procedure might be unclear - just hit the RESET TOKEN button.

For CLI try running particle logout and then particle login again.


#5

Little triangle above says to activate this token. Now how do I activate the token I get?


#6

When I reset my token I get this
image
no idey why you’d get a different result.

Have you tried LOG OUT?

You can also try CLI particle token create to get a new token.
https://docs.particle.io/reference/developer-tools/cli/#particle-token


#7

Ok. But how do I add my device in the list in WebIDE? It was there earlier but I removed it. Now I want to add it again.


#8

First you need a working access token, only then you can add a device to the account connected with that access token.
Once you have that the process would be rather self explanatory again
image

But for that your device (BTW, which device are you using?) needs to be breathing cyan.

Is it blinking green rapidly or with abouth 2Hz?
If the latter, then I’d suspect the “cyan” you see is actually white indicating a restart of the WiFi module which would indicate that you have no valid WiFi credentials stored.
Can you post a video of the behaviour?

However, removing or even unclaiming a device never solves any issues but rather creates new ones.
Hence this warning


#9

I am using spark core
https://drive.google.com/file/d/1-1Xr5nJraLJmcZxRc75t4gfxQDPe4SuW/view?usp=sharing


#10

With device doctor process I get the following message in one of the steps:

Your device should now restart.

Resetting server and device keys

! This device is not claimed to your Particle account.
! Resetting keys for a device you do not own may permanently prevent it from connecting to the Particle cloud.
? Skip resetting keys? Yes

Flashing the default Particle Tinker app

How do I resolve this?


#11

Put your Core into DFU Mode (blinking yellow) and run

particle flash --usb tinker factory -v
particle flash --usb cc3000 -v
particle flash --usb tinker -v

After that put the Core in Listening Mode (blinking blue) and run

particle serial wifi

then follow the instructions to provide your WiFi credentials but don’t use automatic detection.
After that the device should start breathing cyan and you should be set to claim the device to your account again.


#12

After the last step, doesnt breath cyan and comes in same state described earlier


#13

Can you try a different WiFi (2.4GHz only, channel <= 11, no encryption)?
Could it be that you had previously used a static IP on this device?


#14

Try getting the device ID from the CLI then using the web API add it to your account. I use POSTMAN for this step.