Cant claim core

How do I claim two old spark cores that used to work but are refusing to be added to the web IDE now?

I have used putty to add wifi credentials and find out the ID.

Both breath cyan – only one will show up in the web IDE but it refuses to flash with anything or signal. It however claims flash successful but nothing happens, it just breaths cyan.

The other refuses to add completely – I get Could not claim device.

Thanks

Are the devices breathing cyan while you try to claim them?
You can add them via CLI (particle device add <deviceID>) or
Web IDE image

thanks for the reply ScruffR

Yes they are breathing cyan when I paste the ID and click claim. Sometimes 1 will claim but not work after added. I deleted it and tried to add again, this time it will not add.

Unclaiming an already claimed device never repairs things - it usually just adds more issues.
What message do you get when the claiming fails?

on the web IDE it just says could not claim device. (tried chrome, firefox and explorer [explorer does not even give a login box so cant try])

from the android app on a samsung phone, the app does not work, I get an unknown ssid, you cant change it.

from an iphone the App keeps going back to the login screen.

the particle dev destop app no longer works and refuses to reinstall. it used to work then one day it would just load up with a blank white screen.

only luck I have is with putty in adding credentials and getting the ID.

I don’t see any reference to CLI.
Have you not got it or not tried?

With CLI you could try refreshing your Cores this way

particle flash --factory tinker -v
particle flash --usb cc3000 -v
particle flash --usb tinker -v

i have to refresh myself on how to use that.

thanks for the help.

unknown argument ‘factory’

guess my CLi is not setup properly?

What particle --version are you running?

And sorry, all these commands missing the flash keyword (updated now :blush:).

1 Like

Hi ScruffR,

particle --version
gives
1.40.0

particle flash --factory tinker -v
Flash device failed: EPERM: operation not permitted

particle flash --usb cc3000 -v
flash success!

particle flash --usb tinker -v
flash success!

wow! one core seems to be working now. it’s signalling. will try the other

Both working with Tinker -

Thank you very much ScruffR

2 Likes