Two identical devices using Photon, one works, one doesn't

This is driving me nuts. I’ve made two (2) simple Photon devices, They each have just two (2) TMP sensors. One of the devices works just fine, posting to data.sparkfun and all, and the other one just keeps on trying to post and then starts breathing green (Cloud Not Connected.) I then have to put the device in Safe Mode to load any programs, like Tinker. I’ve done a lot of troubleshooting but thought I would post here and see if anyone has any other suggestions.

Things I’ve observed:

  1. I can flash the SAME program to either device and one device works, one doesn’t. That tells me it’s not likely the program.
  2. The faulty device reads both TMP sensors properly as observed on my serial monitor. I’ve gone over and over both devices to make sure they have exactly the same wiring. I don’t think it’s a wiring issue.
  3. The faulty device runs a simple two-TMP readout sketch and Tinkers fine.
  4. I tried particle keys doctor and particle update and it tells me it can’t find any devices in DFU mode although I am definitely in DFU mode (blinking yellow.)
  5. The faulty device shows up in particle cloud list.
  6. When I use particle identify it says: Your device id is undefined - Your system firmware version is undefined.

I’m starting to think it’s a faulty Photon, not sure. Any suggestions for further trouble shooting?

Thanks.

Have you got the proper DFU drivers installed?

Can you swap the devices between the external setup?

With your symptoms, I don’t think it’s a keys issue.
Breathing green would suggest that your code keeps starving the cloud process (for some yet unkonwn reason). Could you add SYSTEM_THREAD(ENABLED) in your code?

Are both devices also on the same system version?

Yes, @Moors7. I ran the particle keys doctor on another Photon and everything worked fine.

@ScruffR - Good suggestion. I completely rewired the external setup, using new TMP sensors, and I made it to where I could easily test it on a different Photon. It works fine on a different Photon but still has the same problem on the “faulty” Photon.

I added SYSTEM_THREAD(ENABLED) in my code and still get the same results, works on one but not on the faulty device. It does, however, give me some strange station names in my serial monitor and on data.sparkfun; things like: gXgf|aBO^NE_9{tJw;Bc4{e.

I believe both Photons are on the same system version but when I run particle serial identify all I get is - regardless of the device connected - is “your device id is undefined, your system firmware version is undefined.” Both Photons were brand new, though, and when I first got them I first flashed Tinker and sat back while they updated.

And, as luck would have it, my other similar device that’s been running fine for days has now decided to go crazy, quick blue flashes with an occasional quick red burst. Time to go searching the posts. I really want to like the Photon - I now own five - but they seem overly unstable. If I have one stay connected for more than 5 minutes I’m ecstatic.

The quick red burst issue usually gets solved with

particle keys doctor <deviceID>
particle keys server

But your other symptoms seem odd :confused:
And that instability is definetly not something all Photons exhibit.

No luck on the particle keys doctor. It tells me:

!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.

I know I’m in DFU mode! I connected a known working Photon and ran particle keys doctor and it worked just fine.

I have five (5) Photons. Every one of them drops the WiFi every few to 5 or 10 minutes even though I’m within 5 ft. of my WiFi. Same thing at other houses. I will say, however, that each of them has one program or another that’s trying to post data to data.sparkfun. I’m going to flash a couple with just Tinker and see what happens.

Still no luck on the instability, even with just Tinker flashed and nothing at all connected. As an example for one device:
(online/offline):
11:19:42/11:20:31
11:21:33/11:21:52
11:38:33/11:49:29
11:49:33/12:28:38
12:28:53/12:29:37
12:29:50/12:31:18 etc.

The same thing with another Photon flashed only with Tinker (nothing connected) and the same thing with another device - LOCATED AT A DIFFERENT HOUSE - that is running my TMP monitoring sketch that posts to data.sparkfun.

And zero luck on the recovery of the formerly good-to-go device. I am staring at it in DFU mode but the CLI acts like it’s not in DFU mode.

This is probably the wrong forum to ask this question but are there any good alternatives to the Photon?

I’ve no suggestion for alternatives ;-), but if you’re using Windows, have you got the DFU drivers installed correctly?
And independent of OS sometimes swapping USB port and/or cable does help fixing such issues. Maybe pressing on the USB recepticle might show if there are some issues with the soldering there.
Also make sure you’ve got the most recent version of CLI (currently 1.17.0) installed.

If it happens to be a soldering issue, a support ticket might be in order.

BTW: The next best thing I could think of might be RedBear Duo.

Yep, I’m using Windows.I could see it being a DFU, CLI, or USB port issue except that all the commands work normally on two other Photons that are here with me. It does NOT work on (now) two of the Photons with me - the other is across town.

As suggested, I tried another USB port, four (4) different cables (all that I know to work with other devices), pushing around on the USB receptacle, and holding my nose at different angles while wiggling my ears. Nothing.

Thanks for all the suggestions, @ScruffR and @Moors7 . You’ve been most helpful.

I must say I’m very happy for the people that are using the Photon successfully. They are really cool devices when they work and I spent many hours dreaming up projects to build around it. My experience thus far has not been thrilling. Out of five (5) Photons, I now have two (2) that are great for Tinker, one (1) that runs an actual program intermittently (at least it was when I could see it online over an hour ago), one (1) that was working but has now bricked, and (1) that never worked properly. I was going all-in on the Photon but I’m not convinced it’s ready for prime-time just yet.

Have you submitted a support ticket for the Photon that doesn’t work? Let me know if there is something that I can do on my end to help rectify this issue.
Feel free to DM.

Kyle @ Particle

Thanks, @KyleG. The Photon that started my discussion today was purchased from sparkfun and I sent them an email Thursday. I’m not sure if I purchased the other one from sparkfun or directly from Particle. I’ll have to investigate that matter. Not sure I can tell at this point.

1 Like

Ok well let me know if there is anything I can do to help you!

Are you using USB hub?

Nope. No USB hub, @ParticleIce.

@KyleG - Since you offered…I submitted a support ticket last Saturday (I guess it’s a support ticket; it was via the Web mail form since I didn’t see another way.) I haven’t heard a peep from anyone and would like to move this forward. Out of 6 Photons, 3 are non-functioning (although I physically destroyed one myself on accident so the count is actually 3 for 5 working.) Thanks!

Thanks for letting me know, I sent you a DM to try and help you get this issue solved.
Kyle

1 Like