Photon Not Discoverable (DFU Mode)


#1

I recently was running code and it caused my Photon to go into SOS mode(think I overloaded the OLED when trying to get it to display Motion Detected/No Motion from the PIR Sensor). I went through the process of putting it into Safe Mode and then attempted to reset it via the Particle CLI Device Doctor. I got a message basically saying my device couldn’t be found. Switched to DFU Mode, same problem. I went back and tried using Zadig, but when I list all devices, there’s nothing there:

Untitled

So I check Device Manager and there’s nothing there either (I know it should come up as Other Devices because I had to reconfigure my Photon in a similar manner):

I went through the process of resetting up the Photon via the setup.particle.io and and I got it breathing cyan, however none of my previous code (outside of the basic LED practice) works.
So now I’m back to trying the Zadig/Particle CLI route but the device is still not coming up (although it is recognized in Tinker and IDE as online with no issues outside of DFU Mode).


#2

Have you tried a different USB port and cable?


#3

Wow that’s such a “duh” moment for me. Switched the cable and now its recognizing. I don’t see anything wrong with the one that came in the maker kit though? Was it possible I shorted it out?


#4

I’d rather suspect broken D+/D- wires. With a short you would rather get a excess power message.


#5

Okay. I also noticed that the new cable has a definite “snap” in where the other slides in and sits snug like I’m pushing it through mud. What do you suggest for cleaning out the port? Want to be sure that’s not going to be a problem in the future.