[SOLVED]I think i have a defective unit... now what?

Hi there.

This week I received two Photons and one is working great. The second unit is attempting to connect to the network but can not connect to the cloud. it breaths blue for a short period and then breaths green. i have tried to go into safe mode and that does not work. i can get to DFU mode but that does not help. I have tried to have it forget the network and start again but as soon as it registers on the network again it starts breathing green again and then nothing.

What should i do next?

Have you put it into Safe Mode and loaded a basic/minimal sketch, like blinking an LED?

if so, then did try to do a simple firmware upgrade using the CLI?

It will not go into safe mode.

yes, try to put it into DFU mode and do the firmware update

I did a firmware update twice. i did the “particle update” and a full firmware replacement with 4.9 and it still does the exact same thing.

mouth to mouth?

:smile:

Is it possible to get Particle to send a replacement for a defective unit?

Particle folks??

try to email them at

hello@particle.io

they are very responsive (i think they man that email weekdays)

Thanks for your help.

Cheers

With the device making those colors, I doubt it’s actually broken.
Try putting it in DFU mode, then do ‘Particle update’, then DFU mode once more, and do ‘Particle flash --usb tinker’. If you show us the output of that, that might help.

How does safe mode ‘not work’, and how does DFU mode ‘not help’? Neither of these is going to magically fix anything, you’ll have to do some things yourself while it’s in either mode.
If you got to DFU mode, you already passed Safe mode. Try making sure you haven’t accidentally missed it. As soon as the LED lights up, let go, that should work.

Also… Did that unit work before, or is this straight out of the box? Did it once connect, and have you managed to flash firmware to it?

Does it by any chance breathe cyan for about ten seconds, after which it goes into breathing green?

So the Particle flash --usb tinker did it.

Thanks so much.

Strange the firmware flash didnt help but this did.

Thanks again.

1 Like

Glad you’re up and running again.

If that helped, it means that there was, in all likelihood, something blocking the connection to the cloud. If I had to take a guess, I’d say you flashed it with some blocking code. If it can’t reach the cloud for more than 10 seconds, it’ll start breathing green.

The reason the system firmware update didn’t help was because there was nothing wrong with it. The user code was the culprit, and that’ll remain in place with ‘Particle update’. Flashing Tinker, however, will replace the user code, allowing it to once again connect to the cloud.

Can I kindly request that next time you don’t immediately jump to “it’s broken, can I get a new one?”, without some more in-depth analysis of what might actually be wrong? I know it’s frustrating when things appear not to work, but in this case, due to the nature of the error and the fix, I’ll assume it was a user fault, not a factory one.

Regardless, have fun, and let us know if you’ve got further questions/issues.

1 Like

Understood Moors.

Will do. Thanks again for your help.

1 Like