[SOLVED]Photon is stuck breathing green


#1

Hello all,

Recently the photon has been working great. However that changed.

I was flashing my own codes and stuff just testing and what not, when recently the photon would connect, (Breathing Cyan), and then whenever I would try to flash, or see if my device was online in the Particle app, the device would blank, then go to a breathing green. No matter how long I wait, it just keeps breathing green.

I’ve tried resetting network keys, Tried factory reset, however I cant get past blinking Yellow.

I dont know what to do now!

  • M.

#2

Turns out I just put it into safemode, Flashed again and I was on my merry way…Phew

-M


#3

Hello all,

I have the same problem. My Photon starts breathing cyan then shortly after starts breathing green. Can´t get past this. Factory reset can´t get past yellow. What is “safe mode” and how can I get past the current mode and flash a new program


#4

Ah, did not select “Photon” in the top right corner of the documentation. When i figured out this I found the “safe mode” description. Found that my program hung on a statement which stopped the loop() and the result was that the Photon started breathing green. To get it out of this I put it into the “safe mode” and downloaded a bug free application :smile:


#5

@Rolf91

My photon is only breathing green as well. I suspect that its hung on a statement. I cant find anything helpful online. Maybe im not looking in the right places. Since the photon is not connected to the cloud how do i go about uploading bug free code ?
When i try to go into safe mode it only goes orange cant seem to get it into safe mode. How did you put it into safe mode?