[SOLVED]Repeated breathing green light

I have been playing with my Photon for a few weeks and all has been well until today.

I tried to flash some new code but every time the Photon restarted (which happened without the cyan flashing that had always happened when I flashed new code before) it just went to a breathing green light. I thought perhaps there was a problem with the code but re-flashing unchanged code that worked fine has the same result.

I can fully reset it and the setup process using my Android phone appears to work fine. However, when it restarts, it initially appears to connect to the cloud (breathing cyan) but then after about 5 seconds it drops into breathing green. At no point does it show up in the mobile app.

It’s clearly not completely kaput as the setup process works exactly as it always has. I also set up an IFTTT recipe to tweet when my Photon comes online. That still works. Unfortunately, that’s all I can persuade it to do.

Any ideas?

I thought I had searched properly for what to do in such situations but rather embarrassingly, three minutes after posting this I realised I should try reflashing known good code in safe mode. That appears to have done the trick so presumably the problem was dodgy code.

Sorry for the waste of bandwidth.