Trying to flash - breathing cyan goes to breathing green


I have been playing with my photon for a while now and have been happily deploying away without issue.

However today I tried (its been a few weeks since I last played with it), and it goes from breathing cyan to breathing green. The web IDE also gives this message:

Flash successful! Please wait a moment while your device is updated…

I tried waiting a while but it doesn’t seem to update or return to cyan and restart doesn’t seem to help either in terms of deploying my code. I’ve even tried by deploying the test blink led code and it does the same thing, starts with breathing cyan and then goes to breathing green.

I’m running firmware 0.4.7

Many thanks



It is nothing to do with flash, it seems from what I have read and what is happening, the photon is not communicating with the cloud so after ~10 seconds the cloud disconnects it and I get the breathing green led.

Put it in to safe mode and flash your code, seems to do the trick. I probably had some blocking code on it from a previous experiment


1 Like

Safe mode should allow you to flash it again :slight_smile:

1 Like