Trouble connecting to Corporate WiFi


I am having trouble connecting my devices to our corporate WiFi. I have been able to connect to mutiple different WiFi networks without issue, but when I try our corporate WiFi it just seems to hang and give up when connecting.

I am using the web tool to connect (Configure Wi-Fi | Tools | Particle) and it reports connected and that the device will reset to connect and then just hangs and never connects.

Our network administrator says they never see any connection from the device.

I then ran the Doctor Tool (Device Doctor | Tools | Particle), flashed the device and then tried to connect to WiFi. I found the debug only reports the following:

0000000292 [system.nm] INFO: State changed: DISABLED -> IFACE_DOWN

0000002606 [ncp.esp32.mux] INFO: Starting GSM07.10 muxer

0000002607 [ncp.esp32.mux] INFO: Openning mux channel 0

0000002608 [ncp.esp32.mux] INFO: GSM07.10 muxer thread started

0000002612 [ncp.esp32.mux] INFO: Openning mux channel 1

0000005304 [app] INFO: Auto-connect disabled

0000005943 [app] INFO: doing wifiScan

0000005947 [app] INFO: Doing Wi-fi scan

0000008478 [app] INFO: wiFiScan resultCount=23

0000027610 [app] INFO: setting credentials

0000027689 [system.nm] INFO: State changed: IFACE_DOWN -> IFACE_REQUEST_UP

0000027697 [net.ifapi] INFO: Netif wl3 state UP

0000027698 [system.nm] INFO: State changed: IFACE_REQUEST_UP -> IFACE_UP

0000030233 [ncp.esp32.mux] INFO: Openning mux channel 2

0000048554 [ncp.esp32.mux] INFO: Mux channel 2 already opened

0000066131 [ncp.esp32.mux] INFO: Mux channel 2 already opened

0000083126 [ncp.esp32.mux] INFO: Mux channel 2 already opened

Then last line "[ncp.esp32.mux] INFO: Mux channel 2 already opened" just keeps repeating.

When I try connecting to other WiFi it goes past this point and connects.

Any ideas what I can try next?

Does the corporate WiFi include any sort of portal where you need to sign in etc?
Or is there a MAC list on the firewall?

The tool won't save the credentials unless it's successful in connecting, so it's likely the device does not have it saved when trying to connect with the Device Doctor.
I'd recommend adding WiFi credentials via the CLI and trying Cloud Debug | Troubleshooting | Particle
(Command Line Interface (CLI) | Reference | Particle)

The Network admin setup a dedicated SSID that only requires a password.
They set it up without any restrictions, with a plan, that once working we would lock down via MAC address.

So no portal.

On the save point you mention, when I restart the process of connecting to WiFi after it hangs, it shows the corporate WiFi as a saved WiFi on the device.

Hi @Jude -

Maybe to help diagnose the issue, you can set up a hotspot on you cellphone, connect your computer to that and then try to set up the particle device again (using the hotspot to connect to internet).

This way, if it succeeds, there is something on the network blocking it. If not well, then we know it is not your network and the IT guy isn't lying :sweat_smile:

Couple of people had this issue, almost all of them ended up being network (LAN) issue.

Hope this helps!!

Are you using WPA2 Enterprise?
IIRC the Argon only supports WPA2 Personal.



I have already done that and can confirm it is only our corporate network that I cannot connect the device to, though I am trying to identify why and what I can do to fix?

(in production these devices need to connect to our corporate network)

1 Like

Thank you, I will check and find out....

If it is WPA2 Enterprise (and it looks like that could be the case) does that mean I am dead in the water?

With the Argon: Yes, as there (currently) are no plans to implement WPA2 Enterprise on that platform.
With the Photon 2/P2: No, not entirely but for the time being, as WPA2 Enterprise is not yet supported (AFAICT).

Unless your IT department finds a way to also support WPA2 Personal.

1 Like

@Jude -

Not being sure exactly what you application is makes it a bit more challenging to justify the following course of action, but maybe you can consider a Cellular device instead, at least for the time being.

To minimize the changes needed to migrate to WiFi ONLY later then, you can use P2 mounted on an edge card that will fit into the existing edge connector of e.g. B404x. There are some users in the forum That have designed an edge card for this purpose and I have been meaning to do this myself for quite a while now.

You can of course include both footprints to accommodate either of the devices, but IMHO it is not the neatest way to do this :slight_smile:


Good news....

Our netowrk admin replied, for this particular WLAN, we’re using WPA2-Personal

So that rules that out as the issue, is there anything else I can try/test to see what the problem could be?

Thank you.

I am not in a position to reengineer the solution, so if I cannot connect to our WiFi, don't know what I can do

Hi @Jude -

Just a thought - Can you put down a dedicated AP or Repeater running WPA Personal and hard wire that to the main router? this way you should be able to have WPA2 (or WEP) on the the decimated AP allowing the Argon/Photon 2 to connect which in turn is then connected with CAT cable to the main router?

It has been a while since my involvement with WLAN to this extent, but you should also be able to connect the dedicated AP the Router in either Bridge mode or AP mode wirelessly. Just not sure whether you would be able to broadcast SSID with WPA2 personal security setting then, but it is worth a try.


Hi @friedl_1977

Our netowrk admin replied, for this particular WLAN, we’re using WPA2-Personal, so that isn't the issue.

though not sure what I need to look at now?

Hi @Jude -

Then my guess would be the firewall :thinking:

Have the admin team tried a packet capture on the access point?
As Friedl mentioned, it seems like something is being blocked here.


They reported it was wide open for our last tests, but I am going to arrange another test and try again

I am going to request that on our next try, thank you

1 Like

@Jude Have you tried connecting your phone or computer to this Corporate WiFi?
If it doesn't work, then you have something else to check and validate with IT.

I did connect my phone to it and that worked perfectly fine.

Thanks for the suggestion. I am open to try anything to get these working :slight_smile:

Hi @Jude -

I used to work in network security for quite a bit (although it was ages ago, hehe) and 9.9 out of 10 times behavior like this was due to overly eager IT guys setting up really ridiculously and unnecessary stringent Firewall rules. Problem is, IT guys are "never" wrong :grin:

Honestly, I would be surprised if it is something other than the firewall, but I have been wrong before :rofl:

Keep us posted please... would like to see this resolves. At least you know that the device his working properly as you connected it via your phone to Particle Cloud correct?

Regards, Friedl.

1 Like