Unable to connect to wifi(obtaining device information)

if i try to connect my particle to wifi, it gets stuck after manually entering the wifi data.
It just says “obtaining device information” again and again.
Can somebody please help me?

I’m assuming you’re using the CLI, and your device is in listening mode? Could you try placing it in safe mode before going into listening mode? Then, use ‘particle serial wifi’ rather than ‘particle setup’.

I tried this and it tells me"No devices available via serial". Furthermore it tells me when i try particle setup “no device is connected via usb” even though it is connected. I followed the steps on connecting via usb this noon and there was the same problem with getting stuck but i could use particle serial wifi.

Is the device in listening mode (blinking blue) and have you made sure you’ve got the proper drivers installed?
Would you mind also trying a different USB post/cable?

1 Like

Ok i tried a cable and i could do the particle serial wifi and it connected and restarted.
Am i now able to flash my apps?

Thanks a lot so far!:smile:

Is it breathing cyan and showing up in your device list in the web IDE? If so, then yes, you should now be able to flash your device :smile: