Not Connecting to WIFI at Office [RESOLVED]

I need some help getting my core to connect to my wifi at the office. I have successfully connected to my home network but at the office it blinks green. I’ve tried using the tinker app to provide the wifi credentials and also used the serial connection to enter the wifi credentials. I have done cleared the wifi credentials but have not tried a factory reset as I just learned how to do that tonight (will try connecting again tomorrow to see if that helped). We are running WEP security. I’ve read some conflicting information about whether or not the core can connect successfully using WEP. Our wifi router is a dell sonicwall which I believe adds a layer of security but I am unfamiliar with how that all works.

I will fill in more information here when I can look at the office tomorrow:

Dell Sonic Wall
WEP, SonicWall?
Small Office
Single Wifi Router
Bend Broad Band
Any network settings that might diverge from the norm: possibly

I was just reading about updating the applying the CC3000 patch but don’t want to go down that path unless the patch actually addresses the problem I am having with my office network. Especially since I have no problems connecting to my wifi at home, which by the way has no security at the moment. Just a hidden SSID.

Any chance you can try WEP at home? :slight_smile:

@pitchlynn, when you did do the serial connection approach to put in your credentials, did you get the choice to use WEP, WPA, WPA2?

If not you might want to (re)flash your Core OTA to get an updated firmware which allows you to choose WEP - your factory firmware might not support WEP, yet.
This has to be taken into consideration after each factory reset, too.

Why didn’t I think of that! Yes I will try that

Yes I had the option for WEP. There was a warning that WEP might not work that was returned after I chose it.

Can you point me to instructions for updating the core OTA? I couldnt figure this out.

@pitchlynn I mean switching your Wifi setup to WEP and giving it a shot to connect.

Did you see 'Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: '? when you do the setup over Serial?

If so, your firmware is probably rather updated and you can leave it alone for now.

So WEP test? :smiley:

1 Like

Right I’m following you kennethlimcp. I think you are suggesting I setup WEP at home and try to connect which would eliminate WEP as my source of problems. I will let you know what happens.

Bingo! :dancers: :dart:

1 Like

Ok, turned wep on at home and it works fine with my core. Im guessing the problem at the office is the sonicwall or router incompatibility.

@pitchlynn, does your network at work have a significant firewall, or something like a landing page or splash screen? The CC3000 (Wi-Fi module on the Core) has difficulties navigating these kinds of networks…keep us posted on your progress!

No splash screen but i think the sonicwall is a firewall which is most likely the problem. Im hoping we can setup a guest wifi which just hasnt happened yet. I wouldnt know what to try next for getting through the firewall

my spark is not connecting to guest wifi network at office…the guest wifi network is free and has no password too!
any solutions for this?

@shashank did you already try the other troubleshooting steps listed here:

@will: let me check regarding the CC3000 firmware manual update and then try again!

Great. Re-running the patch programmer has definitely helped some people who were still seeing the flashing green issue with otherwise acceptable conditions. Hopefully this gets you online!

We’re aware that some of these start-up bugs can be a pain to deal with–let us know if there’s a way we can improve our documentation to help people who run into issues getting started.

I haven’t had time to troubleshoot my office network. Someone at work suggested I use the same key and wep security at home to make sure I am entering it right into the spark core, as in 64bit/128bit encription ascii vs. hex. So, that is my next thing to try. Or maybe try the CC3000 patch programmer.

Time to revive this topic! I took a little break over the summer but am getting my project going again. Since I last posted we changed our office wifi to wpa2 auto psk and it has a new shorter password. I took my core in today and tried to connect using the tinker app. It still was not able to connect (flashing green the whole time). Connects fine at home and to my phones hotspot. I have yet to try adding the wifi credentials via usb (didn’t work back in March when our wifi was set to WEP with a long password). I started down the path of running the CC3000 patch since I had never done that. But I did do the deep update the other day. Does the deep update include the CC3000 patch or do I still need to apply that?

The deep-update is cc3000 patch with other housekeeping so the answer is yes :slight_smile:

Ok, thanks! What should I try next, setting wifi credentials over usb? This is a small office but I’m afraid that I could be up against a firewall or something.

I haven’t read your previous posts but CC3000 doesn’t allow enterprise network with certificate and requirement to enter username and password etc.

A usual home network using wpa/wpa2 with a password and ssid to connect works great!

What is your office setup like?