Can't connect core to wifi

I received a core and can’t connect it to my wifi network. I saw led blinking blue, turning to solid blue, then blinking green and that’s all. App says “no core found” and serial says nothing. I have chip antenna and tried all the following:

  • Be right next to router
  • Factory reset
  • Memory cleanup
  • Connect via USB
  • Use another mobile phone
  • Change wifi channel
  • Applied cc3000 patch

My settings:

  • Galaxy S3
  • Android 4.3
  • Firmware V02
  • Windows 7 with Spark driver
  • Router: D-LINK DI-524
  • Wireless mode: 11 b/g/n Mixed
  • Channel: 11
  • Security: WPA-PSK / WPA2-PSK

Can you help, please? Now I really don’t know what to do next :frowning:

I have exactly the same issue with my office router. My home hotspot works great while my office don’t… In both I use apple airport with wpa2 security password. (Both home and office are the same security settings… Just name change and password)… After the 3 second mode press all I can get is blinking green.

In my house it connects right away and in my office I experience your same symptoms… Flashing great after taking the settings from the smart config…

Very weird!

By the way: I installed the latest C3X patch with no change in behavior.

Try setting the Wifi mode to b/g and not mixed

@lfbittencourt - When you connected via USB, were you able to configure the wifi at all? When you connect via serial, it will not show anything at all until you type “w” or “i”. Make sure it is in the blinking blue mode when you try to configure the wifi using USB as well.

@frlobo - Do you know if there are any firewalls at your office that could be blocking outbound TCP port 5683? I had to get our network admin to allow that exception in our firewall to get my Cores connected to the cloud.

1 Like

That most be it. Thanks for the info!

1 Like

@kennethlimcp I’ll try this mode later. Thanks for the suggestion.

@wgbartley Sorry if I haven’t been so clear… Yeah, I typed “w” and my wifi settings. Last thing I can see is “Spark <3 you!”, nothing more.

To isolate the problem, I brought the core to office and guess what? It works perfectly with the same mobile phone, so there’s something related to my PC or network.

Edit: well, it was something about wifi mode. I changed it some times and it just worked… Thanks for your support, guys, and specially for your suggestion, @kennethlimcp.