Trouble connecting Photon to Pixy2

Hello, I’m struggling. When I plug Pixy2 directly into the computer it works perfectly, but when I connect it with the photon board it doesn’t work, it tells me “error: no response” so it is probably a wiring issue, right?

This is the wiring I’m using:
Screen Shot 2022-10-13 at 1.12.05 PM
This wiring is powering the pixy2; the color recognition works with this setup (the led changes to green when a green object is in camera), but when I try to read blocks with the photon I’m getting a no response error. The fat end of the flat cord is just in the dedicated slot on the Pixy2.

And this is the assumed info on my board pins: Particle Photon Board | Particle Photon

I tried the wiring listed on the wiki (wiki:v2:porting_guide [Documentation]) but it was talking about pin7 and that confused me because there are only 6 pins. I tried according to the wiki ignoring pin 7 and that didnt work at all.

I’m using this library, GitHub - ScruffR/Pixy2: Library to use the Pixy v2 camera with Particle-Devices, and am simply trying ccc_hello_world.ino. This is all local using Here is what my directory looks like:

Any help is appreciated, thank you. Do you think it is a hardware issue, I need to update the photon firmware (though I shouldn’t because pixy2 is supposed to work with a very old firmware of photon 2.0.1 I think), or an issue of software? Thank you.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.