System Update through, Console or Partice Dev - Safe mode not triggered?

Right now I have a P1 with version 5.2.0 in a remote location and I cannot update the system to 5.3.0. I’ve tried using the CLI command particle flash deviceanem system-part1-0.5.3-p1.bin and I’m getting a time out.

I’ve also tried to update the firmware via Particle Dev but I also get a time out.

What am I missing? Should safe mode work when trying to flash firmware from the Dev?

Below is what I’m trying to do in the Console, but nothing is happening


@wesner0019, I don’t believe programming from Dev will trigger safe mode. Flashing Tinker (with the correct target firmware version) from Build will trigger the safe mode healing.

@peekay123, thanks, do you know if updating firmware from the Particle Console from a product will trigger safe mode?

I’d have to ping @Dave on that.


P1s and your products should automatically have safe mode healing enabled. When you flash an app that needs newer system modules, the cloud should automatically try to send an update. If this process fails, it’ll retry it about 5 times before giving up. If you watch your event stream for this device, you should see events indicating the flashes, or safe mode.

Please feel free to send me your device ID, or open up a support ticket at with your details, and we can look into it and see if there are other things preventing your device from updating.

If your device isn’t responding to a flash at all, it might be offline, you should be able to “nyan” your device particle nyan device_id, which should cause your device’s main LED to cycle through the colors of the rainbow. You can use this to confirm with someone on-site that your device is online as expected.



Thanks @Dave, I was eventually able to get it to flash and update. Not sure what happened in between though as I used The web IDE, particle dev, CLI and the Console to try to update, one of them stuck.

If I run into it again, I’ll let you know.