Particle enters safe mode upon boot up and gets stuck in safe mode

Hello,
I have a new P1 which I added to my particle account using it’s soft AP. It was breathing cyan. Now I issued a firmware update using particle cli. This is a first time firmware update after I provision to my account. P1 turned magenta and then it got stuck in breathing magenta(safe mode I believe).

I restarted the P1 but it was breathing magenta instead of cyan. I don’t have usb access to P1 and can’t update the firmware using dfu util.

I can say that the P1 is connected to the internet because it is responding to my Signal commands from the web IDE.
I can also issue a firmware update using particle cli. On the cli it says success but the P1 LED flickers, turns green then cyan and then back to breathing magenta again.

Any tips on how to fix this?

Thanks
Dheeraj

What kind of firmware update?
Just a application firmware update?

In that case try (in DFU Mode and CLI 1.22.0)

particle update

And then reflash the app firmware.

This looks like an system vs. app version conflict.


Update:
Just realised you have no USB access.
In that case you need to do the same as said in the second part of this post
Remote OTA Firmware Update

1 Like

It’s just an application firmware update. From your reply in the mentioned post. I have to manually update the system firmware and then push the application firmware? I’ll give it a try.

A few days back when I used to flash the application firmware for the first time after linking the particles to my account, P1 used to restart 3 times and then finally end up in breathing cyan. I believe the 3 restarts are for - system-part-1, system-part-2 and application-part to update. Is this process not working anymore?

Thanks
Dheeraj

I just caught a post where Particle has realized that the Safe Mode Healer service had got stuck, but should be working correctly again.

2 Likes

I think this is happening again. Today I tried to flash my particle application on P1. The flash succeeded but my firmware wasn’t flashed. I can tell this because, I have a particle variable which can be observed using particle cli. The particle cli reported unknown variable.

I think this must be another issue, since the previous issue was only revolving around Safe Mode Healer, which should not be involved this time, or is your device flashing magenta now?

It’s breathing cyan and is responding to signal from web IDE. However, my application is not running. I think it’s because the P1 didn’t update it’s system firmware. The application is build against WEB IDE so it’s 0.6.2 I believe.

I downloaded the system firmware binaries and tried to update both the parts. But the cli reported error. I think the error message was [object][object] at the end.

Sometimes the running code can interfere with OTA updates - especially with SYSTEM_THREAD(ENABLED).
The first step in such cases would be to enter Safe Mode before trying to flash.

There is no application code in there! This is when I try to flash my application the first time. The P1 is just provisioned to my particle account.

Usually, when I try to flash my application the first time, P1 restarts 3 times. But it didn’t. It only restarted once and ended up in breathing cyan. I can confirm that the flash didn’t went through as I wasn’t able to read the particle variable.