System Mode Manual Still Tries to Connect to Cell Network

I put the Electron into SYSTEM_MODE(MANUAL); but it still tries to connect to the cellular network before running any code. This is my test code. Does anyone know why this is the case. I am using FW 0.6.4.

int counter = 0;

void setup() {

void loop() {
counter += 1;

It should also be noted that the particular Electron I am using had an issue with connecting to the Particle Cloud and is not claimed yet. Could this have anything to do with it? I just tried using Manual mode on another device and it worked fine but I hoped to use the device that isn’t claimed yet for testing while I await the arrival of another SIM from Particle.

The claiming state should not play a role here.
But how do you deduce that it is trying to connect?
Have you double checked that you’re actually running that code? Has happened before that a flash didn’t stick and people just couldn’t make any sense of the wrong behaviour.

I deduce that it’s trying to connect by the fact that it will blink green then cyan despite having the code flashed to it, whereas on the claimed device, the Electron only blinks white and doesn’t try to connect.

As far as checking whether it is actually running that code, the CLI said the flash was successful. I also flashed that code 3 separate times. Is there another way to check whether the flash was successful?

One way to do that is by adding some distinctive Serial.print() messages for each new iteration of code and check whether this actually gets printed.
When you say CLI reported success, with what command did you flash?

particle flash --serial firmware.bin

will even report success when you try to flash a text file or a JPG. So that’s no good indicator.

particle flash --usb firmware.bin

in DFU Mode instead.

I actually did use the latter in all cases, and it reported success.

particle flash --usb firmware.bin