After setting to manual mode, E- does not even try to connect to cellular

I was experimenting on an E- with system modes, manual vs automatic. After that, I reset the E- to automatic, but it now does not try to connect to cellular, and just goes into listening mode.

To fix, I tried particle device doctor from the CLI, which worked, and which should reset everything,
and then particle flash --usb tinker which should make it connect to cellular and the cloud.
But it just goes into listening mode (first it breathes white, then breathes blue, then blinks blue forever). I did the flash via the CLI which reports the flash was successful.
The E- was werking fine hardware wise before this process, connecting to the cloud no problem.

Are you explicitly connecting to cellular and to the cloud in your code? You must do that when using manual mode. You’ll need Cellular.on(), Cellular.connect(), and Particle.connect() in your setup() code.

Also, I’m not sure if Tinker explicitly sets the device back to SYSTEM_MODE(AUTOMATIC). You might want to check the code to see if it does. If not, then you need to flash a firmware that sets the device back to automatic.

I reset the E- to automatic explicitly with

uh, OOPS!! Sorry, I had reset it to semi, not full auto, my bad.
Thanks :grinning: