SSID & Password Format using USB

Obviously others have the correct format… I just can not find it.

Connecting using USB - All is good
Enter i - YES get the ID String
Enter w - SSID: ??? what do I use for the password???

My wireless PW is set in the modem to 22222

WHAT text string needed to enter here??? OCEAN2

Thank you very much.

Like this :smile:

Select the correct security mode, if you are not sure try 3, then 2 then pray it’s not 1

You press ENTER after each entry.

1 Like

Thanks for the picture, however, now I know I have issues… As simple as you portray, mine is “different”.
Enter w RETURN get SSID:
Now I am stuck… never get to Security, or Password:

Terminal is alive, Spark not blinking, just waiting for me???

Help further please…

SOLVED… started using PuTTY as the terminal emulator. Things now working as in your picture. Thank you very much again for the picture.


1 Like

When I used the Arduino IDE, I was getting all kinds of goofy results when the Line Termination was set to none. And CR LF did not work. I had to set it to just LF in Arduino IDE.

Can you try to use Cool Term

It’s available for Win, Mac and Linux. I just tried it on Windows 7 and it worked without changing any settings. Just make sure you have your Core in Listening Mode first, then open Cool Term… and if it doesn’t complain that it couldn’t find any ports, you probably will get it to connect to your Core by pressing the Connect button. If you have multiple serial ports, make sure to select the right one in Options first. The line terminations seem to be correct in Cool Term.

To clarify, when you type i your ID should pop up without you pressing ENTER. Also if you then type w without pressing enter, SSID: should come up. Type in SSID and then press your first ENTER. Security doesn’t always come up for me depending on the network or something else… it could be the ENTER thing. If it does, type one number and press ENTER. Then type your password and press ENTER. You cannot backspace or it won’t work! :slight_smile: so type slowly and accurately.

EDIT: aha… good I see you got it! Must have been the line termination. Putty works for me as well.

1 Like

Thank you again. I have solved my initial issue. Now I can use Putty to properly get ALL the needed inputs into the SPARK. I have had some success using the iPHONE to connect the cores; this success completed with NO wireless password. Since adding a wireless PW, No success. Stopping for tonight.

Terminal emulators: Yes, ARDUINO is one that did not work properly. Next I tried a terminal inside MS Visual Studio; also did not work. PuTTY solved the immediate issue.


Im trying to write my own windows form to interface my spark, and i wanted to have the end user be able to set the SSID and Password using the serial port… i dont want to use putty because i want my own windows program :smile:

Basically im having the same issue as above… i cant figure out the line ending to go to the next bit… ie setting the security type. any ideas as to what the core is waiting for? and where to find it (im compiling local and want a way to call it from my code)

i don’t really understand your issue… :wink:

  1. press w

  2. enter SSID

  3. enter 0,1,2,3 depending on security type

  4. enter password

i enter the ssid and the core doesnt recognise the linefeed or carriage return so it just sits there waiting and never gets to the security type question

so i push w
the core says SSID:
i type in my SSID and the core repeats it
SSID: Hootie81

and thats all i get… does the same in the arduino terminal… i just cant figure out the line endings its looking for… is it \r or \n or both??

Hi @Hootie81

The reader does

      if (i == max_len || c == '\r' || c == '\n')

So I am not sure why it is not working for you. I would try a loop back test to see exactly what you are sending, preferably in hex rather than ASCII just to be certain.

1 Like

Hi @Hootie81,

Feel free to use my implementation as a reference if that helps! - :slight_smile:


Sorry… got it figured… my line feed and carriage returns were not being sent by my app!

Also figured out i can invoke the Wifi credentials reader using the line below, although it did stop my serial port and start it again… so i had to fix that by commenting out the serial.begin(9600);


Now i have a beautiful app that talks to my fingerprint reader!

Thanks for the extra info @Dave but that’s well over my head! just looking at it makes me dizzy!

1 Like

It could also be the firmware / app you’re testing against is really old, have you tried loading the latest tinker onto your core?