Core not connecting and not asking for wifi security type on reboot

Hello,

I have a core that’s been working great for many months. Yesterday, it rebooted after a power loss and wouldn’t reconnect to my wifi…the same network it has been successfully connecting to for a long time. I tried clearing its memory and reseting it to factory default which has worked for my other cores before. This time, it gets to the blinking blue led phase, I can connect to it via usb, but it never asks for what type of wifi network it is connecting to. After sending the “w” command, It asks for the SSID and a password only. I tried connecting it to an unsecured network and it still will not connect. It just gets to the green flashing led phase and sits there forever not connecting.

Here’s the terminal output when I reset it and connect to it via usb:

Your core id is 53ff70065067544818350687
SSID: SpaceCase
Password: 
Thanks! Wait about 7 seconds while I save those credentials...

Awesome. Now we'll connect!

And a slightly different error when using the cli ‘spark setup’ command:

----------------------
Finding your core id

Your core id is: 53ff70065067544818350687

========================================
Setup your wifi

SSID: TheShave
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3   
Wifi Password: elsbells
Attempting to configure wifi on /dev/cu.usbmodem1411
I said: w
Serial said: SSID: 
I said: TheShave

Serial said: TheShave
Password: 
timed out on Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2:
timed out on Spark <3 you!
Something went wrong Serial prompt timed out - Please try restarting your core
Potentially unhandled rejection [2] Serial prompt timed out - Please try restarting your core (WARNING: non-Error used)
Potentially unhandled rejection [4] Serial prompt timed out - Please try restarting your core (WARNING: non-Error used)

As you can see, it never offers the option of choosing the security type using a serial terminal and it has some sort of exception when trying with ‘spark setup’.

Any help would be appreciated.

Thanks,
chad

I had a similar problem not long ago and after factory reset it also went back to the old CC3000 stack.
So I flashed the deep-update and everything worked again.

I ran the instructions under “flash it” here: https://github.com/spark/cc3000-patch-programmer but that didn’t seem to fix it. Is there another update I should try installing?

Have you tried it the spark-cli way spark flash --usb deep_update_2014_06, too?
This is how I did it.

See
https://github.com/spark/spark-cli#performing-a-deep-update

Just tried that…thanks, but no dice. It still doesn’t ask for the security type when I input the wifi credentials.

Did you get any error messages from spark-cli?
Are you sure the deep-update did succeed?
Was your Core flashing yellow correctly (dfu-mode - just to make sure ;-))?

Sometimes one factory reset seems to be not enough, if something went terribly wrong beforehand.

I just tried the deep update two more times. It finally got it to a state where it’s asking for my wifi security type again. I enter the credentials, but it just blinks green. Never gets to cyan.