Spark Dev unable to login [solved]

So I’ve been using the online IDE and its been going great. But since I’d like to throw my code in source control I thought I’d download the local tool and give it a whirl.

When I did and tried to log in, it would not accept my credentials, no feedback other than what I assume is a redbox around my password (which is plaintext), no error message saying ‘bad password dummy’, no nothing. I downloaded it from and, both with the same result. I’m running Win7 64bit.


Can you try the same account at

If you have Spark-cli installed, it should use the same account without you logging in.

I can log into fine (just an aside won’t load in Chrome but will in IE).

You should try incognito mode--works great with Chrome for me.

No go for incognito. There is something about the lack of ‘www’ in the address that keeps Chrome from connecting to the service (the error code is ERR_CONNECTION_TIMED_OUT)

with www, works fine, without, timeout error.

Oh I see. That is because “” and “” are different computers with different IP addresses (and in fact is really many computers each with a different address to help share the load). You should use the www version.

1 Like

That’s fine but is really is sidetracking from the initial point of the post, which is the offline development tool is not working. I only mentioned the difference in the two addresses because I was asked to try the other URL and was being thorough.

Hey @nicholasstg,

The Spark-dev is not an offline development tool.

Can you make sure you are online and login again?

I said ‘offline’, I meant ‘local’, I realize I need to be online for it to work (the log in sort of gives it away). I was hoping it was something that would let me save my work locally so I could use source control and the like, if not that’s fine and I can investigate other things (the documentation is not clear) but does not solve the issue.

Sent in a PR based on your feedback here:


This isn’t solved.

The tool might not be suited to the purposes I had in mind for it, but it still won’t login.


1.) You asked why you cannot login. The answer is you did not connect to the internet

2.) There are local tool-chains that you can setup like:

1 Like

There is a misunderstanding, I did not try using the tool without connecting to the internet. I have always tried using the tool (and logging in while connected to the internet). I apologize if there has been some confusion.

I will try the netbeans solution when I get some spare time to do so.

@nicholasstg I also encountered the same issue you had with not being able to login (exact same red box).

The issue I found was that the input field doesn’t accept the password being copy/pasted in. If you manually type out the password hopefully you should be able to login.

hope that helps.

@rorybladen that solved the issue. Thanks so much.

I had given up on any sort of resolution to this.