Spark Core worked well but now is solid magenta

After what you see in the video you should get

  • a longer white blink followed by
  • white flashing again followed by
  • very brief breathing white followed by
  • a longish blue followed by
  • blinking blue (listening mode)

But if you can get DFU mode, try flashing your Core via USB, maybe this helps the Core to cough out whatever bothers it :wink:

Depending on your Core factory firmware, you might have to reflash the deep update in order to gain access to open and WPA/WPA2 networks (which might cause the solid magenta, if you try connecting to any of these without deep_update_2014_06).

I’m not sure, but I think to remember reading about repetitive panic attacks (red SOS codes) triggering the Core to perform a factory reset by itself, which would also wipe the deep update off, causing the need to reflash this first.
This might have been the original cause of your pain.
Just a guess :blush: :wink:

I tried to flash the Core via USB. The Core made now the same thing breathing cyane 3seconds and then stay on magenta.

I think you are right, I remember some red flashing before having problems.

How can I do the deep_update_2014_06?
I can’t do Flash via Spark CLI, having problem with instaling the Spark-cli.

This should help:

1 Like

I tried over the air firmware update with lots of reseting, network changeing. Not work.
Via Spark Build IDE can’t because isn’t connected to the cloud.

remained option is to install Spark Cli

I’m not a programer just knowing some C coding.
Tried to install the Spark CLI: but I need a good to folow topic.

Since most references to deep update would recommend Spark CLI it would be good to get this to work - once you got it you wouldn’t want to miss it anymore.
What are your troubles with it? What OS are you on? Have you seen this for example?

But since you said you can flash via USB, you’d just need the bin file and flash it. I’ll find it and post you a link here.

Edit: Found my local copy first - I’m sure there is a Spark one on GitHub, but just to get it to you ASAP :wink:

I have Windows 7

That tutorial I started to read before your posting :smile:

I did something
install nodejs, OpenSSL, Microsoft Visual C++ 2008 Redistributable Package
do in the nodejs comand prompt : npm install -g spark-cli

when was done, sended a new command: npm update -g spark-cli
without responce.

next command
C:\Users\xxxx>spark cloud login
Could I please have an email address?
and a password? *********
Got an access token! xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
logged in! { ‘0’: ‘xxxxxxxxxxxxxxxxxxxxxxxxxxxxx’ }
Using the setting “access_token” instead

now I’m lost…

I done a new command under the DFU mode
spark flash --usb deep_update_2014_06

C:\Users\xxxx>spark flash --usb deep_update_2014_06
Apparently I didn’t find a DFU device? util said
Error writing firmware… no dfu device found.

For this to work you need to have your Core in DFU mode (yellow blinking).

Edit: Sorry, you mentiond you were in DFU mode already - that’s odd.
Did you hear the Windows “Attach USB device” sound, when you put the Core in DFU mode? Did it show up in Device Manager before you tried flashing?

in device manager saw that before flashing.

another try
before re installing the dfu driver the “npm install -g spark-cli” command worked but after reboot the system, I have errors in the same command, I tested the dfu driver and working good, it recognise the Core.
I will try another way, call a friend, is a programmer and in this afternoon we try again.

finaly my friend solve the problem installing the spark-cli on linux
it was very hard for me (I didn’t understand how he did it to working)

I’m sure my code was too bad and started the reset of the core.
After changing the code the red blinking disapeard, and working good.

next time I will try to describe what I done.

thanks for helping me


Hi I have same problem. I guess core can’t connect to the cloud after flashing… well to be exact. After flashing code (via web build, lcd 20x4 and bmp85 code) it worked, and every time I reset core ( by pressing reset bottom or re-powering) code worked. And led was flashing cyan. BUT I couldn’t flash any other code. Web build always timed out. I even tried put core close (about 1.5m away) router. Didn’t work.
I tried cli using provided tutorial. things I did:

  • npm update -g spark-cli run without errors, even after reboot.
  • spark cloud login getting access token.
  • spark list sparky (*****) is offline.
  • And I guess I can put core in dfu mode. Under Device Manager I can see libusbK USB Devices > CORE DFU
  • and I geting same error:

C:\Users\xxxx>spark flash --usb deep_update_2014_06
Apparently I didn’t find a DFU device? util said
Error writing firmware… no dfu device found.

Does it mean I should try Linux way? But usually Linux an’t friendly with me.

… googling wile writing and I guess I found problem:

  • spark serial list Found 0 core(s) connectrd via serial:
    but still can’t find solution…
    Ideas are welcome.

Update: googling more and found what core should be in listening mode flashing blue for spark serial list to work. And its do work. finds core on port 13. But not in DFU mode.

And stil cant make it work

then why they say … that in order to use particle-cli the core must be in DFU mode… but now you say that in order for particle-clid to detect the device in the serial ports… in needs to be in listening mode… this doesn’t make any sense. Im unable to see the device in the terminal, either way anyway. I get “! serial: No devices available via serial” but Im in MacOSX

Hi @omarojo

The Particle devices open the USB serial port under a few different conditions:

  • When your device is in DFU mode and flashing yellow. The system code running on your device is expecting to talk to the dfu-util program, which downloads new code (user or system code) to your device over USB serial. Particle CLI uses the dfu-util program when you do particle flash --usb tinker or similar commands.
  • When your device is in listening mode and flashing blue. The system code running is wait for you to use a terminal emulator like CoolTerm or screen to connect and enter WiFi credentials. Alternatively, the particle CLI can do serial commands for this mode too when you do particle setup wifi
  • When your code is using Serial.begin(baudRate). In this mode you are in control over the serial port.

Cool… that clarifies things. I will get “No devices available via serial” even though the core is blinking blue. So…

Are you getting that message from a particle CLI command? Which one?

this is what I get… I see no CORE… and my Core is in blinking blue for listening mode. Is not a cable issue btw.

omars-mbp:game omar_juarez$ ls /dev/tty.*
/dev/tty.Bluetooth-Incoming-Port /dev/tty.Bluetooth-Modem /dev/tty.OmariPhone6-WirelessiAP
omars-mbp:game omar_juarez$ ls /dev/cu.*
/dev/cu.Bluetooth-Incoming-Port /dev/cu.Bluetooth-Modem /dev/cu.OmariPhone6-WirelessiAP

Hello @feroxktm,
after a factory reset I’m having similar problems, mainly the solid magenta error.
I can put the Core in DFU mode, but the CLI cannot detect the Core:

>particle flash --factory tinker
Apparently I didn't find a DFU device? util said  dfu-util 0.8
Error writing dfu device found.

I think the problem may be a missing driver, where can I find the DFU driver you are referring to?
My Windows 7 Devices list shows a “CORE DFU” without a valid driver installed.

So I can’t flash my Core and install the updated firmware. And I can’t connect to the cloud. Help!!


Why is Google so great…?
I found this: [Installing DFU driver][1]
So I could install the DFU driver and now I can flash from USB a new firmware

>particle flash --usb deep_update_2014_06

But I can’t find the .bin file anywhere on my PC nor on Github! :frowning:
It is missing

No such file or directory: Could not open file binaries/deep_update_2014_06.bin for reading

And this post does NOT help: [deep-update-source-file-for-spark-cli][2]
as the Github link does not work! :frowning: :frowning:

OK, I had to re-install the CLI (update did not work):

npm install -g particle-cli

DONE! Finally. feeew :flushed:
[1]: Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]
[2]: Deep Update (source file for spark-cli)

I reply to myself… :frowning:
I have a solid magenta on my Core again!
I can connect through serial and configure the WiFi, but after rebooting I get the solid magenta again.
I tried to update the firmare with

particle flash --usb deep_update_2014_06

but, even though the DFU device is apparenty recognized by Windows, I receive this error:

Apparently I didn't find a DFU device? util said
Error writing dfu device found.

What do I do now? Should I reinstall the DFU driver? :confused:
I’m discouraged!



I installed the CLI again, the DFU driver again and finally managed to flash the firmware with:

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

Anyway I still had problems connecting to the WiFi AP (Linksys or Android phone), I have a flashing green after any reboot/reset, so I also did:

particle flash --usb deep_update_2014_06

Then a partial success: I could configure SSID and password, had a flashing magenta, but at the end flashing blue again! I can configure the AP details from the serial, but then it goes back to flashing blue again!! :frowning:
HELP! Is my Core at the end of his life?

1 Like

Also had solid magenta.

On Ubuntu/Linux installed with npm the particle-cli
$ sudo npm install -g particle-cli

if needed the dfu-utils but gave instructions on how to load it using apt.

put core into yellow download, hit reset, mode, hold only mode on core till yellow.
then flashed with
$ sudo particle flash --usb deep_update_2014_06