Spark Core worked well but now is solid magenta

Hello @feroxktm,
after a factory reset I’m having similar problems, mainly the solid magenta error.
I can put the Core in DFU mode, but the CLI cannot detect the Core:

>particle flash --factory tinker
Apparently I didn't find a DFU device? util said  dfu-util 0.8
Error writing dfu device found.

I think the problem may be a missing driver, where can I find the DFU driver you are referring to?
My Windows 7 Devices list shows a “CORE DFU” without a valid driver installed.

So I can’t flash my Core and install the updated firmware. And I can’t connect to the cloud. Help!!


Why is Google so great…?
I found this: [Installing DFU driver][1]
So I could install the DFU driver and now I can flash from USB a new firmware

>particle flash --usb deep_update_2014_06

But I can’t find the .bin file anywhere on my PC nor on Github! :frowning:
It is missing

No such file or directory: Could not open file binaries/deep_update_2014_06.bin for reading

And this post does NOT help: [deep-update-source-file-for-spark-cli][2]
as the Github link does not work! :frowning: :frowning:

OK, I had to re-install the CLI (update did not work):

npm install -g particle-cli

DONE! Finally. feeew :flushed:
[1]: Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]
[2]: Deep Update (source file for spark-cli)

I reply to myself… :frowning:
I have a solid magenta on my Core again!
I can connect through serial and configure the WiFi, but after rebooting I get the solid magenta again.
I tried to update the firmare with

particle flash --usb deep_update_2014_06

but, even though the DFU device is apparenty recognized by Windows, I receive this error:

Apparently I didn't find a DFU device? util said
Error writing dfu device found.

What do I do now? Should I reinstall the DFU driver? :confused:
I’m discouraged!



I installed the CLI again, the DFU driver again and finally managed to flash the firmware with:

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

Anyway I still had problems connecting to the WiFi AP (Linksys or Android phone), I have a flashing green after any reboot/reset, so I also did:

particle flash --usb deep_update_2014_06

Then a partial success: I could configure SSID and password, had a flashing magenta, but at the end flashing blue again! I can configure the AP details from the serial, but then it goes back to flashing blue again!! :frowning:
HELP! Is my Core at the end of his life?

1 Like

Also had solid magenta.

On Ubuntu/Linux installed with npm the particle-cli
$ sudo npm install -g particle-cli

if needed the dfu-utils but gave instructions on how to load it using apt.

put core into yellow download, hit reset, mode, hold only mode on core till yellow.
then flashed with
$ sudo particle flash --usb deep_update_2014_06