Spark core dead?

When I last used my Spark Core 2 days ago, everything was fine. Today, however, the LED is blank and nothing I do seems to turn it on. I’ve tried a factory reset with the buttons on the core, and nothing happens. (Yes, I’ve ruled out a problem with the wall power adapter or usb cord and I’ve tried connecting it to a computer). When left plugged in, the usb connector on the core begins to get very hot.

I plan to take some voltage readings on it tonight. Is there any chance my Core isn’t totally fried? Any ideas on anything to try?

Is there a warranty on the Core (I’ve only had it about a month and a half)?

Thanks for your help,
Cody

It’s possible that the voltage regulator is dead. It’s located directly underneath the USB connector, and uses that as a sort of heat sink, which is probably why it’s hot. Try the voltage readings you mentioned, and let us know what they are. Those could shed some light on what’s happening (or rather, what’s not).

There’s some info here about warranty. However, like it says in the aforementioned document:

since Spark products are prototyping tools intended for novices and experts alike, we cannot replace units that break during use outside of the specifications described in Spark documentation.

It’s unlikely that a working Core will randomly break. It’s more likely that you’ve accidentally short-circuited it (I’ve been there, done that, wasn’t fun…) Perhaps you put 5V on some non-5V-tolerant pins, damaging it.

Let’s see what the voltage readings say, perhaps it’s still save-able :smile:

1 Like

When plugged into a USB wall adapter, I read about 4.7V between VIN and GND. And about 0.66V between 3V3 and GND (and also between 3V3* and GND). So this sounds like the regulator is busted, right?

Is it possible to power the Core by providing 3.3V on the 3V3 pin (since the Core seems to be busted anyway)?

I really don’t think I did anything to short it. It was sitting inside a clear plastic box when I used it last, and two days later it was still in the plastic box when I checked on it and saw the LED was out.

That indeed sounds like a dead regulator. I think you should be able to power it with 3.3V on the respective pin. It might be better if you de-soldered the regulator then.

I could be that you used a bad USB adapter which at some point decided to put a lot of noise or excess voltage into your Core. If you’ve got a scope you could try to measure your supply.

Before you proceed, let’s get a second opinion from some of the other Elites, or perhaps @ScruffR.

1 Like

@Moors7, I was just in the middle of writing this, as your answer popped up

Yes, you can power your Core via the 3V3, but be careful to provide a nice and clean filtered 3.3V - no more!

As your 3V3 voltage reading suggests your voltage regulator in deed seems to be dead.
But if you can get your Core to work powered via 3V3 (NOT 3V3* !) your Core is good for a second life.
You can replace the regulator rather easy.

There are some possible reasons for a regulator to die.
One might be overheating due to prolonged confinement in a too small plastic box :wink:
Or as @AndyW has said in another thread, some cheapish power supplies are not filtered good enough and might cause the regulator to oscillate (or exceed the voltage limits stated by its data plate)

1 Like

@cody, to add to what those other folks said, you may need to remove the regulator depending on how it failed. You can actually replace the regulator as other members have in order to repair your Core.

It cannot be stressed enough (as we are learning more and more) how important a good quality power supply can affect a Core. We see this kind of failure caused more and more by cheap (oscillating) supplies killing the regulator. Invest in a high quality supply! :wink:

1 Like