My Spark Core is dying all the time

Hi folks,

well, I’ve got a Spark Core running my rather small installation. When I want to power it externally (with 5V) I can run my installation just fine. When I power off the Spark Core and wait for about a few minutes and then want to power it again, the Spark Core seems dead. No LED is blinking whatsoever.

However I can revive it by doing a factory reset and reconfigure it with the CLI when it is only connected via USB with my PC. I can’t perform a factory reset while the SparkCore is still on my breadboard and therefore part of the installation.

This is a new problem to me. When I finish my installation (couple of months ago) everything was working just fine. And even after not using the installation for quite some time, I never had those problems. But only now, after some time passed I’m having these problems.

Edit:
Event though I think it is irrelevant for this issue; here’s my code:
http://pastebin.com/igeqEhsL

Edit2:
I have tried using an older firmware (0.4.7) and the problem still exists.

The Core doesn’t even come to life when you take it out of your breadboard, and power it via USB then?
How does your cuircit for powering the Core look?


BTW:
In you code you have something like this

  int val = map(x, 0, 4095, 0, 255);

While map is quite convenient the easier way to get the same result is this

  int val = x / 16;
  // or even simpler
  val = x >> 4;

There is no need to have motorVal a float, since analogWrite() will only take the int part of it and map() only gives you an intas well.

1 Like

Nope. The LED connected to D7 is the only sign of life I get when it is connected to USB and I hit the Reset button. But its only shining very very very very weak.

Well, I’ve got a 24V PSU, and I’m using a LM2596S buck converter to get 5V which is directly and only connected to the SparkCore.

Well,

I just revived one of my Sparks by doing a factory reset (connected it via USB). Then I unplugged the Spark and it seemed dead. I left it plugged in and after about 1 minute the Spark came back to life.

Maybe that narrows down the problem. I have two Sparks and they behave exactly the same… is this some kind of old-age illness since its a spark core 1.0 ?

You need a power shield.

Huh? Why?

@newclear, could you shoot a video of that?

Rather than making these really short, unfounded, answers, perhaps you could elaborate on why he might ‘need’ a power shield. I can see ways to do it without, nor does the lack of a power shield immediately explains the issues.