[SOLVED] There was a network error while connecting to the cloud

I am a serious newbie. I am trying to connect my first Photon and have not been successful.

  1. Attempt using the Particle app on my Android phone and I get the error “Setup process couldn’t disconnect from the Photon Wi-Fi network. This is an internal problem with the device, so please try running setup again after resetting your Photon…” I held down the Reset button until I got the fast blue flashing light. I released the Reset button and it starts blinking blue slowly. Tried connecting through the Particle app again and get the same message. Have done this more times than I can count.

  2. Since I was having no luck with the Particle app on my phone, I attempted to try connecting using my MacBook. I am not very good at using Terminal on the MacBook but I muddled my way through and got the process going. However, it tells me “There was a network error while connecting to the cloud…” and “We need an active internet connection to successfully complete setup.” I did this several times as well all with the same result.

The MacBook Pro is on the wireless network, it is what I am using to type this message. I don’t know why the Photon is having issues.

Detailed instructions on how to get this to work for a newbie would be great!


Ok do the following:

  • npm update -g particle-cli (might need sudo in front)
  • place the device in DFU mode
  • particle update
  • place the device in Listening mode
  • particle serial identify (you will get the deviceID)
  • particle serial wifi (setup wifi)
  • Photon should eventually be breathing cyan
  • particle device add DEVICEID (be sure to use the actual device ID)
  • particle device rename DEVICEID name_you_want
1 Like

@kennethlimcp - Step 6 - Photon shoudl eventually be breathing cyan. It doesn’t look anything like the example here - [https://docs.particle.io/guide/getting-started/modes/photon/#connected][1] it is a faster blink. I moved forward anyway…

When I do the particle device add DEVICE ID step, I get a “Failed to claim device” error seen in the screen shot below. Then it starts blinking cyan for about thirty seconds and then an orange blink and then back to cyan.


Ok so you are seeing a blinking cyan + occasional yellow? That indicates bad keys.

Let’s do this

  • particle keys new junk
  • particle keys send deviceID junk.pub.pem (you will need your device ID)
  • restart the Photon

Hope this works!

Okay, so I did the two steps you mentioned and got successful messages. I then figured I need to go back to the steps you gave me yesterday so I went to the particle serial wifi step. This came back successful and it said my device would restart. When it did, it flashed fast cyan for about ten seconds and then an orange/red fast and then back to cyan. It did that for a bit and is now just flashing fast cyan.

Still fumbling my way…looking for as much help as possible to get this project moving forward.


You should just require the steps to fix the keys i mentioned

I did a particle keys doctor DeviceID and now it is breathing cyan.

Should I be seeing it on my DHCP Client Table with the name I assigned it when I did the task particle device rename DEVICEID name_you_want step?

Even though it appears to be breathing cyan, I am not seeing it on my wifi network. Is this normal?

Can you do a particle list and see if it is online and connected to the :particle: :cloud:?

When I do a particle list this is what I see. It gives me back the name I gave it, the DeviceID and says (Core) is online. Does this mean I am connected to the :particle: :cloud: successfully and am ready to attempt to finally program it to do what I got it for?

Yes indeed…The Core should also be breathing cyan. To test, run this command: particle call deviceName digitalwrite "D7,HIGH"

The light next to pin D7 turned on. I was able to send a “D7,LOW” and turn it off.

Thanks for your help @kennethlimcp. Next up trying to flash my program to the Photon and get this project moving!

1 Like