[Solved] Spark Core over USB affecting mouse pointer

Spark USB issue
After weeks of VERY SUCCESSFUL operations, connecting the core using USB is trashing my PC. I have been using USB to set the SSID when needed and to debug code sequences to a serial window.
(WIN 7/ 64 bit/ Intel i7). Was the USB interface MODIFIED???

After connecting CORE 1 to the PC, less than 30 seconds, the mouse pointer is uncontrollable. Moves on its own, LEFT click will not work; can not close open windows. Have to manually (Reset Button) restart the PC. After restart, PC is stable until I connect the CORE using USB. CORE 2 was able to connect without trashing the port, but now is “blocked”.

CORE 2 Now having Problems

  1. Core 2 now WILL NOT connect to the USB, and obviously does not lock the port. (has slightly different code )
  2. Occasionally during BOOT, two RED flashes are observed before the cloud is connected.
  3. Windows is not automatically installing a driver.
  4. When CORE 1 is connected, USB driver is activated, and then 30 seconds after connection the PC is trashed.


  1. Connected USB a few hours ago, observed windows loading an updated driver; never saw windows doing that before.
  2. Other devices are able to load on the USB wire and operate properly (mouse, ULTRA port expander)
  3. Loaded an updated version of code that was being modified all day; nothing fancy, simply small changes; then it appears the problem started.
  4. The updated code in CORE 1 added some Serial.println functions; old code versions also had serial prints.

Suggestions are appreciated…

There was a thread recently about the Microsoft serial mouse driver not playing nicely, but darned if I can find it now. I’ll edit and post a link if I can, and if someone else doesn’t beat me to it.

Edit: And with the next search I found it. Try the solution here: https://community.spark.io/t/issues-using-serial-debugging-mouse-moving/1200/8 and see if it doesn’t fix the problem.

1 Like

That’s the thread! :slight_smile: It’s the combination of writing data over serial, and Windows getting possessive and wanting to think the core is a Serial mouse. Disabling that device via the registry should fix it.

Thanks guys!

1 Like

Thank you all for the quick help that stopped my investigation yesterday.
Comcast net down last night, just now getting back to testing.

Is there any interest in WHICH statement caused the error???

I will be doing testing later tonight to clean the code for me only.

Changing title to be more searchable and less inflammatory :wink:

Thank you Zach for the advice and concern. However… can you say “less Inflammatory” without yourself being inflammatory??? I will attempt to make better titles.


I believe I have experienced similar problem with a Mac. Not sure if it is related though.

Mark this SOLVED. Edited the Windows Registry as recommended. Operation is functional ALL evening. Back to fighting code issues.

1 Like

Haha fair enough :slight_smile: glad you got it working!