[SOLVED]Photon stuck at blinking cyan

Hi there,

I recently turned on my photon and flashed a new sketch to it. Unfortunately, after uploading the new sketch, the status LED is stuck at blinking cyan which indicates that it is connecting to the cloud.
In my sketch, I set up a static IP for the photon and I probably typed the wrong DNS address. Could this be the problem?

I’ve tried setting the photon up again via my iPhone and the CLI but it still has the same issue. I uploaded new firmware and a new sketch that resets to DHCP in DFU but to no avail.

Any help would be appreciated.

Since we can’t see your code, we have to assume things.
So I guess your reset code uses default SYSTEM_MODE(AUTOMATIC) which will not execute your reset procedure since that code only runs after getting contact to the cloud - which it can’t due to the previous sketch (unless you’ve put that code in STARTUP() which we can’t confirm or deny without code either).

So as a rule of thumb: Post your code, to save us from guessing (wrong) :wink:


Sorry about that, the following is the code that I suspect caused the problem:

IPAddress address(192,168,0,100);
IPAddress netmask(255,255,255,0);
IPAddress gateway(192,168,0,1);
IPAddress dns(192,168,0,1);
WiFi.setStaticIP(address, netmask, gateway, dns);


I used the wrong DNS address here I suspect.

This is the code I uploaded to reset it:

void setup() {

void loop() {

I’ll try adding SYSTEM_MODE(MANUAL) In the reset code to see if that works. Thanks!

Thank you so so much!!! :grinning: :grinning:

To fix the issue I just added SYSTEM_MODE(MANUAL) to the top of the reset code and then flashed it with DFU mode and particle flash --usb firmware.bin

I then sent tinker to it using the same method and it works!


Thanks @ScruffR for helping out!

1 Like