[SOLVED] Photon Solid Red LED?


#1

As soon as I plugged in I got solid red led. Can some one tells me what solid red means and how can I get out of it. I see blinking red in the documentation but no solid red.

I tried getting into DFU mode but the solid red color did not change.

I have the photon for more than 6 months now without a hitch.


What does it mean when the RGB led is solid red?
Unable to change Mode on photon
#2

That is no usual behaviour, and hence not documented.

Can you recall what happened before that?
Can you put your device into DFU Mode and reflash Tinker (particle flash --usb tinker)?
Can you take the device out of the breadboard?
Can you try a different power supply/USB cable?
If you have a second Photon, can you try to power this one off the 3v3 pin to the 3v3 pin of the “faulty” device?


I have moved several double posts of that question back into this one here.
Don’t double post!


#3

@kennethlimcp, I am having a similar issue but my photon all of sudden is stucked on solid Red Led. I tried your procedure but nothing happen. I also could not get into dfu.safe mode either.

Anu idea?


#4

Let me see what can be done.

What is the led sequence upon powering up?

What were you doing that put it in that state?

Can you put it in dfu mode and do the following:

// Photon
dfu-util -d 2b04:d006 -a 0 -s 0x8000000:0x100000 -U photon_backup_replace_with_device_id.bin

#5

@kennethlimcp, thanks for replying.

  1. As soon as I plug in the usb power, the LED went straight to solid red. No boot sequence.

  2. I was trying to unclaim the device with the following. I was guessing the particle js call but you pointed out to me I have to use particle.remove device in my earlier thread. But I really don’t think that this bad command should put my photon to this state.

particle.unclaimDevice({ deviceId: ‘DEVICE_ID’, auth: token }).then(function(data) {
console.log(‘device claim data:’, data);
}, function(err) {
console.log(‘device claim err:’, err);
});

I can’t get into the safe mode with any procedures. Any help is much appreciated. I have another photon running the same code with no issues for months. This one was working well until today.

Thanks.


#6

@kennethlimcp, I can’t put it into DFU mode either.


#7

Definitely not helpful if it is solid red on boot. Did you remove it from any connected circuitry?


#8

@kennethlimcp, no I haven’t remove anything. I am using the photon with pre-soldered headers. One thing I noticed is that if I put my finger gently to the metal part of photon, the red light went off and as soon as I lift my finger it comes back on.

Also when I plug the photon the the relay shield from Particle, relay 1 and 2 (I think pin D3 and D4 ) are HIGH. But I only have DS1820 temp read on my D3 PIN of my code and nothing on D4.

I would pretty much like to know the answer what caused the photon to brick before I put out the devices to our customers.

Thanks.


#9

@kennethlimcp, yes, I have remove it from connected circuitry. Sorry I misunderstood your question. I tested with Photon only also and it was given me solid red led at boot and stays on.


#10

Sorry about that.

Do you have a programmer shield or jtag around? If the led is still turning on, we might be able to find the root cause.

Also, don’t press the metal lid cos it shorts the power to ground. :slight_smile:


#11

@joe4465, I am having a similar issue. My Photon all of a sudden went solid red led. can you tell me how you got out of it? I tried putting it on safe mode but no avail.

I have been running the firmware for a while. which seems to be quite stable. The thing I did was I tried to call invalid

particle.unclaimdevice({ deviceId: Device_ID, auth: token }).then(function(data) {…

after that I noticed the solid red. I am not sure that should actually cause it.


#12

Sorry if you’ve tried this already: Unplug the Photon from power, press down on the MODE/SETUP button, and then re-apply power. Keep holding the button until it blinks yellow and then release. It should continue to blink yellow indefinitely. Does this happen? If not, what does happen?


#13

@ScruffR, thanks for your reply. Here are the answers:

  1. Can you recall what happened before that?
    I tried to unclaim the device via Particle JS as follows:

I guess this one and found out it was wrong:

particle.unclaimDevice({ deviceId: ‘DEVICE_ID’, auth: token }).then(function(data) {
console.log(‘device claim data:’, data);
}, function(err) {
console.log(‘device claim err:’, err);
});

After I did this:

particle.removeDevice({ deviceId: ‘DEVICE_ID’, auth: token }).then(function(data) {
console.log(‘remove call response:’, data);
}, function(err) {
console.log(‘An error occurred while removing:’, err);
});

I use my device id and my auth token.

I noticed the device went to solid red led and stuck.

  1. I tried putting it in DFU mode with following two methods:
    a. hold down both reset and setup, release Reset while holding down Setup. But the RED LED never changes
    b. and hold down setup with usb cable unplug and plug it in while holding down Setup. still no change in LED

  2. Can you take the device out of the breadboard?
    Yes. I took out of the breadboard and tested the device also. still solid red led.

  3. Can you try a different power supply/USB cable?
    Yes. still red solid led.

  4. If you have a second Photon, can you try to power this one off the 3v3 pin to the 3v3 pin of the “faulty” device?
    Yes. I just tried it. Still solid red LED.

Thanks for your suggestions. Please let me know if you can think of anything else. I sure would like to know the answers on what caused it.

Thanks.


#14

@harrisonhjones, I tried this several times. Still red LED. How long do I have to hold it down after USB power is plug in? I held down more than a minute but no change in LED color.

Thanks.


#15

It should be pretty instanatious. One last thing to try: with the device powered up can you measure the voltage between VIN and GND and also 3.3V and GND and report back?


#16

@harrisonhjones, I got 4.78 V and 3.32 V respectively. I have also tried powering it up through 3.3 V and GND pins from my other Photon as @ScruffR has suggested. But still solid red led.


#17

Fill out a ticket here: https://docs.particle.io/support/support-and-fulfillment/menu-base/ and mention this thread. I’ll get a replacement sent out


#18

@harrisonhjones. Thank you for offering to replace my device. Just to make sure I am filling it out correctly, the link you sent have several options. Do I select the portion Do you have a different question? and Send message. Where do I put my address? in the Message section.

Just making sure I got the right link. Please confirm. Thanks.


#19

@harrisonhjones can the faulty unit be sent to me or @BDub?


#20

I am having a similar problem. I have tried all the suggested solutions and no works. The particle can blink magenta (but can not maintain it i.e. goes back to red immediately I release the mode button). After magenta it procedures to yellow and states blinking yellow although when I try running photon doctor I get and error. The error is;
"The Doctor didn’t complete successfully. Cannot read property ‘code’ of undefined

Please visit our community forums for help with this error:
https://community.particle.io/