[Solved] Photon not working with Pololu Motor driver

Hi folks,

I’m at my wits end with this project, in theory it should be easy, I’m controlling two motors using the VNH3SP30 on a carrier from Pololu, the basic idea is that I can send a command to the Photon with then activates the motor in one direction or another depending on the state of some limit switches, once it hits one the motor stops and the new state is saved. I originally had this circuit working on a breadboard just fine, but now that I have transitioned to a custom OSHPark PCB that I designed things have gone south.

I’m attaching the schematic and board files from Eagle as PDF’s if they help.

Some things I have tried:

  1. Checking all voltages, 12V in for the motor driver, 5V in for the driver logic, voltages for enable lines and PWM lines, all are normal and within range, plus this setup is being powered by a bench power supply capable of 10A, so no worries on the supply side.
  2. Making sure the driver works separately from the PCB, I desoldered it and checked with another micro controller, worked just fine.
  3. No shorts or other obvious signs of trouble on the micro or driver side

I do, however, have an idea of what might be going wrong, when I enable the motor driver the indicator LED’s come on but very dimly compared to when the driver is used in a breadboard, further when I try to connect a small motor to the output terminals the LED cuts out entirely, making me think that it’s not getting enough current from somewhere, but where?

If it helps to know, I have a two channel oscilloscope and a multimeter for test equipment

Any help or ideas are much appreciated, I’m just about ready to chuck this thing across the room.

schematic and board view: http://cl.ly/fmei

I am not an expert, but this happened to me and was that I broke some hardware with a very powerful soldier. Did you soldered the board ? Maybe some component is broken.

Turns out my Photon had issues from the factory, nothing to do with my circuit or motor driver.