[SOLVED] particle update fails to update Argon over USB

Hey, I was having problems updating my Argon via particle CLI today, and the troubleshooting steps in the template helped me solve my problem, so I thought I'd share the details of what fixed things for me in case anyone else is having this problem as well:

TL/DR: Plug the Argon directly into your computer (no USB hubs) and disconnect all other USB devices before running the particle update command

from template...

  1. Search in the community for similar reports
  • No other similar issues found
  1. Create a new topic / thread and include the “[ISSUE]” prefix - this will help us quickly differentiate bug reports from general questions / discussion
  • Done
  1. Verify you are using the latest versions of the CLI - there’s a decent chance we’ve already fixed your issue. Here’s how to update
  • Verified
  1. Disable Antivirus - some antivirus programs interfere with the CLI - temporarily disable or explicitly grant higher privileges and confirm your issue is still present
  • Disabled anti-virus and tried again, same result
  1. Bypass USB hub / extensions - if you are working with a device and are seeing issues related to its USB connection, try disconnecting all USB devices and reconnecting only your Particle device directly to you computer’s USB port.
  1. Check your USB Cable - Likewise, if you are having issues connecting to your device over USB, try using a different cable. You’d be surprised how many “power-only” USB cables are out there.
  • n/a
  1. Avoid Cloud Storage Drives Targeting a project in a Dropbox / OneDrive / Google Drive directory? Try moving it to a standard directory
  • n/a
  1. Please provide clear steps to reproduce your issue - what chain of events lead to the issue? what happened? what did you expect would happen?
  • n/a
  1. Capture Verbose Error Log - run your failing command again using the --verbose flag - e.g. particle <cmd> --verbose - and share the full error details
  • (I tried this but the output was the same:)
C:\Users\Boompy>particle update
Updating argon e00fce687054767e5ec5b31a to latest Device OS version
[█████████████████████████] 100% | Flashing argon-system-part1@4.2.0.bin
Update success!
C:\Users\Boompy>particle update --verbose
Updating argon e00fce687054767e5ec5b31a to latest Device OS version
[█████████████████████████] 100% | Flashing argon-system-part1@4.2.0.bin
Update success!
  1. Include Environmental Info
  • Operating System?
  • CPU Architecture (32/64 bit? arm?)
  • Particle CLI Version (run particle version )?
  • Contents of your particle directory - ls -a ~/.particle (macOS / linux - bash, etc), get-childitem ~\AppData\Local\particle (windows - powershell)
  • How was the Particle CLI installed? (standard or advanced?) see docs
  • What terminal / shell are you running the Particle CLI within? (powershell, bash, zsh, cmd.exe, etc)
  • What Particle hardware are you using? (argon, boron, etc)
Device name TOMS_TOWER
Processor Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz 4.00 GHz
Installed RAM 16.0 GB
System type 64-bit operating system, x64-based processor
Edition Windows 10 Home
Version 22H2
Installed on ‎11/‎25/‎2022
OS build 19045.3570
Experience Windows Feature Experience Pack 1000.19052.1000.0
C:\Users\Boompy>particle version
PS C:\Users\Boompy> get-childitem ~\AppData\Local\particle

    Directory: C:\Users\Boompy\AppData\Local\particle

Mode                 LastWriteTime         Length Name
----                 -------------         ------ ----
d-----         7/11/2023  10:25 PM                .npm-cache
d-----         7/11/2023  10:25 PM                bin
d-----         7/11/2023  10:24 PM                node-v16.20.0-windows-x64
d-----        10/21/2023  12:18 AM                node_modules
d-----         7/11/2023  10:25 PM                NSIS-Tool.3.0.8
d-----         7/11/2023  10:24 PM                tmp
-a----        10/30/2023   9:48 AM             53 autoupdate
-a----        10/30/2023  10:29 AM         304398 error.log
-a----        10/21/2023  12:18 AM         824516 package-lock.json
-a----        10/21/2023  12:18 AM             58 package.json
-a----        10/21/2023  12:18 AM             60 plugin-cache.json
-a----         7/11/2023  10:35 PM         160842 Uninstall.exe

I am using a Argon

Thanks for sharing this solution!