Cannot update old device (0.8.0-rc.27)

Hi there,

I have some Xenon and Argon devices that I go a while back, and currently I am trying to update them from the old firmware 0.8.0-rc.27. I have managed to use the CLI to update via USB with a device in DFU mode, to version 1.1.1. But I have one device that just refuses to update, when i run the command from terminal it looks just as it should and it returns “Flash success!” but the device is not flashed. I can also not signal the device from the IDE or program it, it seems to be stuck. If anyone could give me some advice on how I can proceed that would be greatly appreciated.

Stuck in what mode?
What command have you used to update it?
What does particle serial inspect (in Listening Mode) give you?
Do you have most recent CLI installed (particle --version)?

  • So it is actually breathing cyan, so it seems to be connected - and I can see it in the Particle Console.
  • I used “particle flash --usb link-to-file”
  • The serial inspect command gives me the following: “Platform: 14 - Xenon
    Modules
    Bootloader module #0 - version 301, main location, 49152 bytes max size
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
    System module #1 - version 1104, main location, 671744 bytes max size
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
    Bootloader module #0 - version 201
    User module #1 - version 5, main location, 131072 bytes max size
    UUID: E9B9603DBC8CF07F552DF44169FD3125597B35C2B133355F5E6B0C931C120FE0
    Integrity: PASS
    Address Range: PASS
    Platform: PASS
    Dependencies: PASS
    System module #1 - version 326”
  • I have updated the Particle CLI and I am running version 1.42.0

One more clarification–when you say it’s still reporting 0.8.0-rc.27 – where is it reporting this? Is this on the web console or when you perform the command particle identify while it is listening mode?

This would suggest you are not on 0.8.0-rc.27 anymore :wink:

Particle Identify gives me:
Your device id is xxxxxxxxxxxxxxxxxxxxxx
Your system firmware version is 1.1.1

Which would suggest, as ScruffR writes that the particle is indeed running 1.1.1. But in the web IDE it still says “0.8.0-rc.27” and I am unable to signal it or reprogram it :frowning:

The issues are most likely related, then.

The web interface only updates the device OS with the last reported version from the device itself. If a device does not come online after an update, it will not update the console with its new version. Likely where the discrepancy is coming from.

Your device is definitely 1.1.1, but isn’t coming online for some reason.You mentioned the device is breathing cyan, though? That would suggest it’s connected.

It may be valuable to make use of boron-clouddebug here (You should just need boron-clouddebug-v1.1.0.bin. This will give more insight into what the device OS is actually doing.

Can you post a screenshot of that?
What does Particle Console report for that device?

You can also try this (while the Xeonon is breathing cyan)
image
and check again.

When I try to follow the guide I get the following error when trying to flash it: “Error writing firmware: Incorrect platform id (expected 14, parsed 13), use --force to override”. If I try to use --force the device just gets stuck in DFU mode and I am unable to get it back to listening mode.

Aaaaand, now after flashing back to 1.1.1 it works :exploding_head: I had actually tried to flash 1.1.1 multiple times without luck.

I know the --force switch is suggested, but that is bad (!) advice. There should be disclaimer to warn you: "Only if you know what you do!"

Obviously the firmware was built for a Xenon and flashing it to a Boron will cause problems without doubt.

When you get the platform warning you should double check whether the binary is really for your platform (particle binary inspect <yourFirmware.bin>)

2 Likes

Thank you for that advice :slight_smile: