SOLVED: Particle Photon...dead?

I purchased a couple 2-relay boards from along with Particle Photons and IFTTT firmware. I’ve installed both on two different gates that I have and wired the first relay on each one to the gate controller, which is basically the same as what you’d do for a garage door opener. The exception with the gate controller is that while you can do the “momentary” command to blip the relay and have it open the gate and close it back, you can also just send an “on” command and the gate will stay open until you send the “off” command.

Been working great for weeks. I control the gates with various IFTTT recipes including having iOS widget buttons on my phone. I noticed yesterday that one of them was no longer working, however.

Upon investigation, it wasn’t talking to the cloud. In fact, it was in setup mode according to the blue flash. So I removed the existing device in the Particle app and proceeded to set it up again. Everything seemed to go like normal in the app. I configured wifi including password and then I got check marks on all things in the app…except “Verifying ownership.” I get an X there.

Thanks to someone with a bit more expertise than me with these, I was told maybe it was a key problem. So I installed the CLI utility and successfully setup the key again:

particle login
particle identify
particle wifi serial
put it in DFU mode, then
particle keys doctor

All of that worked without error right down to:

Okay! New keys in place, your device should restart.

But when I attempt to set the device up again using the iOS app, I get the same sad X when it’s verifying ownership. Anything else I can do to troubleshoot this?


In cases where things go wrong with a device, it’s never really helpful to unclaim the device as reclaiming it might get a bit hairy at times - especially with the mobile apps.

You can, however, use Web IDE ( to claim and rename a device quite comfortably.
And when you see the device listed under your account, you can just ignore the claiming error uttered by the mobile app :wink:

Err, okay. But it isn’t appearing any more. It’s gone, and nothing I seem to do makes it come back in any form.

FWIW, I am pretty sure this isn’t an environmental problem, either, as I had a spare Photon and I swapped it into the gate setup, configured it, and it’s been working fine for a day.

Am now just trying to bring the original one back to life on my workbench with no love. I can update its main firmware, using the firmware utility, but I can not get it to complete setup in the app.


Not appearing where? Not even in Web IDE?
Is it breathing cyan (or magenta when put in Safe Mode)?
Can you claim it via Web IDE via ADD NEW DEVICE in the target flyout?
What does happen when you try?

I simply get “Could not Claim Device” when I try in the Web IDE using the identity given by the “particle identify” command with it plugged in via USB.

So then I did:

particle doctor

And walked through it. Then I was able to claim the device via the web IDE, but it only seemed to claim it, not let me configure it. So I went into the iOS app and added it again, and this time I made it all the way through all the steps with check marks.

Except it reset itself from the config and now will only slowly flash green. I know of no reason it can’t get to the network. This is so weird.


And again to rule out environmental conditions, I took ANOTHER spare Photon out and was able to bring it online with no problems.


Okay, on a whim I tried ‘particle doctor’ again. THIS TIME it did more. I didn’t realize that it actually errored out after asking which antenna type the first time I tried it. This time it went to completion. And it showed up in the iOS app like it was supposed to and was running Tinker.

Then I reflashed it with the 2relay app using the web IDE and now that’s working again.

SO WEIRD. This one doesn’t give me warm fuzzies, but it does appear to be working again.


1 Like

Are you sure that the wifi was properly set? You can’t claim a device that isn’t connected to the Particle cloud at the moment, so if you aren’t breathing cyan you won’t be able to claim it. Green generally is going to signify a state where you aren’t connected to WiFi properly. Try using the mobile app or CLI to delete the stored WiFi credentials and then add the correct credentials. If you can get it to breath cyan, I would then recommend trying either the Web IDE or the CLI command “particle device add <particle_id>”

Edit: didn’t realize you had gotten it to work, maybe mark it as solved or ask another question if there is something unresolved - I’ll leave this here though just in case someone else stumbles upon it with something similar.

Point taken, though I’m not sure it’s “solved” so much as “fixed.” I still have no idea why or how this happened. As for wifi, no, I don’t think that was it. I could ping it internally and see that it was alive and on my network, with no reason to believe it was being blocked from the network.

I really think the thing was corrupted somehow strange.


1 Like