Solved - Particle CLI Question - DFU Electron Firmware Upload Help

I’m trying to use the Particle CLI to load the 0.6.0-rc.1 Pre-release firmware on the Electron over USB.

I’m trying to follow this instruction set to put the new firmware on the Electron:

I have the latest version of the Particle CLI.

I paste the code into the command prompt window and get this error message.

I have downloaded the 3 new bin files but I’m assuming that I need to let the command prompt know where they are but I’m not sure.

What should I be doing to let the CLI know where the Bin files are located?

Fixed.

I just put the .bin files in my main directory and it worked just fine.

Mod’s feel free to delete this if you feel its a waste of space :smiley:

1 Like

Never a wasted space! You never know when someone else might run into the same problem.

1 Like

Actually, if you have CLI included in your path, you can place the files wherever you like, you only need to either be in that respective directory (cd \to\that\folder) before you execute that command, or you’d need to provide the full path and not only the file name :wink:

e.g.

particle flash --usb \wherever\these\files\live\system-part1-0.6.0-rc.1-electron.bin
1 Like

I tried to navigate to the directory in the CLI, but I didn’t know I need to put the “cd” before the path :smiley:

Thank you for the tip!

This week I figured out how to use the CLI, and I found the Particle DEV software. For some reason, I thought people were using the CLI to do the offline coding :blush: The Particle DEV is a nice piece of software.

1 Like