[solved] Particle CLI - "particle cloud login" just hangs

Hi Guys

I’m trying to update my Electron via the particle-cli app, however when I run the command “particle cloud login” or even “particle login” my command line just hangs.

I have node and particle-cli installed and updated, and I am running on a Mac OSX

If I run “particle” I get the following output:

Welcome to the Particle Command line utility!
Version 1.11.0

Usage: particle <command_name>
Common Commands:

setup, list, call, get, device, identify, flash, subscribe
compile, monitor, login, logout, help

Less Common Commands:
token, binary, cloud, config, function, keys, serial, udp
update, variable, webhook, wireless

For more information Run: particle help <command_name>

Any ideas?

Thanks in advance

weird… it’s working fine for me. Can you see particle config identify and whether it points to the :particle: cloud?

Ok, I have only myself to blame.

I uninstalled particle-cli and as i started re-installing I noticed a warning, that i had previously missed about the node version.

I proceeded to upgrade node, and reinstall particle-cli and am now logging and working without any issues.