Particle-Cli unable to login or claim spark core on local cloud

Particle-Cli will say I successfully login, but then after trying the next command it will always say I must login first, even though it had just said I had logged in successfully. I then tried logging in with random email and password and it still said that I had logged in succesfully. Also after starting the local cloud it always says there are no users even though I have ran particle setup multiple times. When running particle setup it will hang forever and the stage where it is suppose to claim the spark core, though the local cloud server does say that the spark core is connected and online. The spark core is currently connected to the local cloud and breathing cyan but there are no users so I can’t access it. I have tried particle-cli from both windows 8.1 and on debian where my local cloud is being run from.

Sorry for the long thing of text, is this a known issue?

  • Did you switch a profile?
  • Have you done a particle login?

By swith profile do you mean swich the config to point it to my own server? I have done that, I have also tried logging out and then logging it and that would not work either.

I just tried and some changes to the CLI does not allow the creation of a new account.

Can you tell me how did you create a new user account for the local :cloud: and paste the log output from the server here?

I created a new account using particle setup command. It says I can make an account, then tells me it found a spark core connected to usb and prompts me to claim it. Then the particle-cli hangs on claiming the core even though the spark core conencts to the server successfully. I don’t think the particle-cli is actually making an account, i think it just says it did successfully, because it does the same crap when I try to login in, if i just put a random email and password it still says it logged in succesfully.

How can I get the log from the server?

I uploaded what is displayed from the server terminal and the particle cli terminal ran from the server.

So do you have any idea how I could create an account and get login working? I tried removing my username from all of the profiles in my .particle folder and then it prompted me to create an account when I ran particle setup again. It said it created the account but login still won’t stick.

Ok did you upload the core public key? Once you do so, reboot the server

I had already uploaded the core public key. If you look at the log I uploaded you will see that the core already succesfully connects to the server. The problem is I can not make a user so that I can interact with the spark core. I just restarted the server and started the spark-server and I still can not log in. It says I created a user succesfully and that I logged in succesfully but the server continues to say that no users exist and I particle-cli will tell me to login when ever I run a command that requires you to be logged in, even though it said I logged in already.

What does particle config identify say?

It says that I am using my local_cloud config and that my api address is “http://127.0.01:8080” like it should. It says that i have no token.

This is a different issue, but is the email/password different for the cli than my account? The cli still only accepts an old password, even though i have changed it on the webpage.

I don’t see how that would affect the local cloud but yes it is the same email and password as for my account.