[SOLVED]No status led lit on my photon

I uploaded a program to my Photon this morning and it goes through flashing green/flashing blue then steady blue
for about half a second then the status led goes out, not lit at all.
Whilst the led is flashing, the photon connects to a com port then disconnects when the led goes out.
I can get it to go through this sequence by pressing the reset button but it still goes lights out every time.

It has been fine up to me uploading a program this morning.

Can this be recovered or do I need to order another photon?

Thanks for any help

Could you try placing it in safe mode and flashing Tinker?

1 Like

Thanks for the response

I went into safe mode and uploaded the simple LED flash program.
That worked fine and now the photon is breathing cyan again…phew!

Reloaded the suspect program and sure enough it puts the photon’s lights out again so that program
is the problem…

Anyhoo, I’m back up and running and have learned about “safe mode” thank you :smile:

Phil (total photon noob)


If you show your code, we might see your problem.

One common cause for this is use of Wire (I2C) without pull-up … and of course the use of RGB.brightness(0).

1 Like

Now I feel a complete fool…

The program I was trying to use was the one for the Sparkfun Photon Weather Shield…(connecting to Wunderground)
Just noticed the program includes a 5 minute deep sleep between each data send…

So, the lights all go off for 5 minutes and I though it was broken…


Hmm, sounds like that might have something to do with it :wink: Glad you found it though. Happens to the best every once in a while.