[SOLVED]IFTTT doesn't show my PARTICLE anymore


I had a simple IFTTT script running to toggle a pin0 and now I don’t see the PARTICLE any more in the IFTTT setups.
So my previous DO Button doesn’t work anymore and when I try to create a new one I cannot select a core.

My code is:

int garage = D0;

void setup() {
Spark.function(“nyan”, nyanHandler);
pinMode(garage, OUTPUT);

void loop() {
//nothing to see here!

int nyanHandler(String cmd) {
digitalWrite(garage, HIGH); // Turn ON the LED
delay(1000); // Wait for 1000mS = 1 second
digitalWrite(garage, LOW); // Turn OFF the LED
delay(1000); // Wait for 1 second

Very strange, it always worked before, I reflashed the core with a new access token, it didn’t solved it.
Within IFTTT I get the message that the options are unavailable ???

Does someone have a clue ?

I think that IFTTT uses a different access token to talk to your account, and by default that might be subject to expiry too. Recently a few IFTTT rules I had started failing and I got automated emails from IFTTT as the rules were disabled because it could no longer access my cores.

I’m not in a place where I can look up the access token voodoo right now, but if you check the forums, I seem to remember a post from @kennethlimcp (I think) that showed how you could read and modify your token settings, even the ones that were set up silently for you by things like the IFTTT integration.

I could be wrong, but it might be something to look into.

Thanks @AndyW, it was indeed so that somehow the channel got disconnected. Once I logged in with the Particle login ID in IFTTT it all worked again.

You made my day.

1 Like