IFTTT Function List Not Showing Up


#1

I’ve been using IFTTT for some projects for a while now with great success!

However, yesterday I tried to create a new IF that triggers a function on my Particle Core’s but when I try to create the Recipe, the functions are unavailable:

I’ve reconnected the channel just in case but still no luck.

Can anyone double check if its just me. Or if it has something to do with the Spark/Particle renaming on IFTTT.

Thanks


#2

@Carsten4207 is the core online when you did that?


#3

Yes sir. I actually have quite a few Core’s online that should show some functions. But nothing show up.


#4

Weird. I guess nothing was changed…let me try mine now :smiley:

@Carsten4207 just tried and thing seems ok. The name has changed to Particle.

Try again? :smile:


#5

Tried again with same result.

I did also try to delete the channel completely and readd it but no success.

I notice the name changed from Spark to Particle between 5 PM (Eastern) and now 10 PM on my side. Earlier this AM it was still Spark.

Maybe I need to wait a bit longer?


#6

Hmm i tested after you posted and it seems ok.

Can you activate the channel and see if your email address for IFTTT matches the :spark: account?


#7

It sure does.

Now my access token changed recently and I made a new one via the web interface. The new access token never expires. Probably nothing related, just figured I’d mention it.


Disconnect and Reconnect Particle Channel
#8

Hey all!

I’ve been working with the IFTTT team and discovered an issue where our refresh tokens were expiring before the channel had a chance to use them. This meant your IFTTT channel authorization would expire after 90 days. I’m fixing the issue now, and it should be included in our next release so this problem should go away moving forward. So if something IFTTT-y isn’t working, and it’s been a few months since you signed up with us at IFTTT, now you know why :slight_smile:

Thanks!
David


#9

Perfect! Let me know when the change is implemented so I can verify on my end.

Thanks!


#10

Any update on progress with this issue?


#11

Hi @MisterNetwork,

Sorry about that! The refresh token expiration fix (what’s causing channels to need to be re-authed) is on our staging environment now, and will be included in our next push to production. It looks like there was a problem re-activating the channel which should now be fixed, sorry about that! It was a complication with the renaming of the channel.

Thanks,
David


#12

Hi, I am also seeing the same message

IFTT worked fine when the channel name was Spark but now even after re-connecting the channel I only get the ‘Options Unavailable’ message.

I see the last post was about 2 weeks ago so I don’t know if it has been resolved for posts previous to this.


#13

seems this popped up again
I’m having the same
problems using IFTTT even though it worked 2 days ago


#14

Actually it’s a problem with connecting to the service, I have the photon only 10 feet from the router and can’t get a connection that lasts


#15

My 2 Photons are not showing up in IFTTT. However I can see my core!
I tried to disconnect and reconnect Particle in IFTTT to no avail.
What’s strange is that IFTTT lists my Photons for the other services (monitor variable, monitor device status, publish events).
[SOLVED] I reflashed the Photons, and now I can see the function in IFTTT