[SOLVED]Flashing yellow

My photon was working fine and after some weeks without touching it, it does not anymore… If I reset it, it blinks green, then starts to breath cyan for 15 seconds then the color change to green and it keeps that way (breathing green). If I try to hold SETUP/RESET, release RESET, it flashes magenta then start to blink yellow forever. I can hold the button for 60 seconds and it just stay yellow.
In that state, if I try to call particle flash --usb cc33000 for the next 5 seconds, it says:

Error writing firmware... Cannot open DFU device 2b04:d006

If I try the command after 5 seconds of yellow blinking, it says:

Error writing firmware... No DFU device found.

The dfu-util -l has the same problem. Is there something I still can do or is the core dead?

Are you sure you got a Spark Core and not a Particle Photon?

Does it have components at the botton (Core) or not (Photon)?

Sorry, yes it is a photon :confused:

OK, then you can’t flash the CC3000 update, since it’s only for the Core.

And the Photon does not have a Factory Reset either.

To get your device back on running, put it into Safe Mode (breathing magenta) and just flash your code as usual.

Thank you, that worked!

1 Like