[SOLVED] Connection issue, red flashing light and tri color light

With the help of @harrisonhjones I was able to make sure I had all the programs correctly installed on a PC (Thank you!). I wasn’t able to get things going on a Mac due to some root error. It was determined that the green LED was dead/burnt out which was why in DFU mode it was flashing red. Although the core was being recognized on the PC, it was unable to connect to wi-fi due to a hardware issue. I got a new core and was careful to not accidentally static shock it and was able to set up everything with ease. All colors and modes were working perfectly. The only thing that took awhile was downloading the firmware for the choosatron stories because I had saved them to the wrong folder. All is good now, thanks to everyone for their time and suggestions :smiley:

Original post below:

Apologies in advance if this has been posted but I couldn’t seem to find a similar issue. I had no problem connecting my core last week but now that I have firmware to download when I turn on the core it won’t connect. When I tried to reset the wifi info, it just turned off. When I try to do a factory reset it flashes a constant red. I unplugged everything and when I plugged it back in, its intermittently flashing white, red & blue at the same time. I’ve followed all the trouble shooting tips and can’t seem to get the core connected again. When I tried to manually connect via USB, it didn’t recognize the core. I’m not really tech savvy and the spark core came as part of another kickstarter project (choosatron) so any help would be appreciated. Thanks!

My setup/info:
iMac 2009, OS 10.9.5 & Iphone 5s
Router make and model - Verizon FiOS Actiontec MI424-WR
Network security- WPA2
Environment: Home
Network topology (number of routers and/or range extenders, estimated number of devices connected to network): 1 router and 5 devices
Internet Service Provider: Frontier
Any network settings that might diverge from the norm: Not that I know of

1 Like


So you are taking the spark core out from the Choosatron? @jerrytron might be able to help more :stuck_out_tongue:

1.) When you perform a factory reset, the core should be blinking blue

2.) You will now be able send in Wifi credentials via USB.

Let us know how it goes? :wink:

Sometimes multiple factory resets are required to wipe any jammed firmware parts propperly.

Thanks for the responses :smile: A bit of an update. I got the program Coolterm to work. When I put the core in listening mode and start to enter all the wifi info, the light turns solid blue. When I hit enter, it shuts off and starts blinking with white, red and blue going at the same time. Still no luck with a factory reset, it won’t flash yellow, just constantly flashing red.

1 Like

@radonchak, any chance of videoing this down for us to take a look?

Great suggestion! :smiley: I should have done that when I first posted. Not sure how to get the video on here so I created a youtube channel and posted it there (clickly click for the video :smile:) . The video is just under 2.5 mins. First thing I did was the reset, then when it appears in listening mode, I went into Coolterm. When the light goes solid blue, I’m entering the wifi info and when it shuts off, I had just hit enter in Coolterm to connect. Then the 3 blinking lights happens. Unfortunately, I only had my phone to use so you can’t really see all 3 lights clearly.


The light sequence looks correct but the colors do not match up. Factory reset happened correctly ut the choosatron default firmware might have been loaded instead.

Also, i’m not sure if you are able to claim the core id or something.

I guess @jerrytron will have to take over from here :wink:

Hey @radonchak!

I’d like to isolate the problem a bit.

  1. Unplug power to the Choosatron board if it is connected, and pull the USB from the Spark Core.
  2. Pull the Spark Core out of the Choosatron board.
  3. Plug USB back into the Spark Core.
  4. Try putting the Spark Core into DFU mode again with no external plug.

Do you still experience the unexpected colors / behavior? Can you report on this or record?

Doing a factory reset should put the Spark Core Tinker firmware on. Choosatron firmware doesn’t replace the factory firmware on the Spark Core.

Thanks @radonchak, and sorry for the trouble!



Hi @jerrytron. Thanks for the suggestion. I was able to pull it out of the board, only slightly bent one leg :stuck_out_tongue:. Unfortunately, I got the same errors as when the chip was in the board which I did record. It was on my phone, so not the best quality but I put it on youtube (spark core error video) .

So I think the first issue, is simply that the Green component of your Spark Core isn’t lighting up. Red and Blue however work fine. So when it is blinking Red instead of Yellow, it’s because it should be mixing Red and Green. Blinking Purple should be White, but is missing Green. The good news is, knowing this, we should be able to figure it out.

Let’s start from scratch then, since obviously the core has been factory reset (and feel free to do so again so we know what state it is in). Instead of blinking yellow, then eventually white, you’ll get blinking red, that switches to purple (indicating factory reset). The blinking blue is actually then properly blinky blue mode. First, if you don’t mind, get back to blinky blue, connect with CoolTerm, and hit ‘i’ to get the Core ID returned. Copy this ID and please email it to me / message me. I may need it to help depending. Then also in blinky blue, set the WiFi credentials again. Let it reset, and see if it goes into a breathing mode (normally turquoise, though I’d think it would be pretty close to that even without Green). Let it sit to see if it auto-updates the built in Tinker firmware (will start blinking purple).

For actually getting the Choosatron firmware on, the current option, until the easier option is ready, is installing DFU-Util and writing the firmware & stories that way. For you, it means going into the flashing Red mode after holding mode and reset and letting go of reset. Once in flashing Red, running the DFU command listed on the choostron.com/start website.

Let me know what you think of all this!


1 Like