[SOLVED] Cloud actions make photon to stop working

I am having a weird time with my Photon.
It’s an old Photon, and was running an old fw I copied just to blink a led.

Today, I decided to start working on it again.
Did an OTA, and it entered safe-mode. Did a reset, and then had trouble connecting it to Wifi.
The only method that worked was on my desktop, with Linux, and a wifi-dongle. Other attempts with Windows didn’t worked.

But now, I just cannot go further. Cannot re-flash tinker (dfu process says error on address and/or signature) from CLI.
But a Tinker is installed, since I can operate it from Android App. So, it’s connected and alive. D7 controls a led.

Then I tried to upload a new FW, using 0.6.2 (it’s 0.4.3 currently), and the moment I click FLASH, the breathing cyan hangs. Tried this several times. Then I tested just “SIGNAL” from the particle.io/build particle devices. Same thing: the moment I click SIGNAL, the light hangs. Right after stopping breathing, tinker also stops functioning. When I reset the Photon, Tinker starts working again.

What am I missing here?

Search the forum, I believe when updating from that far back, somewhere it was mentioned to update to 5.2 or 5.3 first, then update to the newest firmware. This is just off of memory, so double check that.

I agree with this recommendation.
Jumping from two ‘major’ releases is never a good deployment practice.
From 4, go to 5, then 6.
At least that worked for me on some of my old units I had never unpacked.

The requirement to use 0.5.3 as stepping stone for a "multi-version-skip update "is (currently) only required for the Electron as this is the version where the system has been changed from being split in two to being split in three parts.
But the safest way to update a Photon or an Electron is via CLI and DFU Mode

particle update
particle flash --usb tinker

But if you want to update OTA you need to be patient once the magenta phase starts as this will involve several restarts for each module to be flashed (including your own firmware twice - pre & post update). If you interrupt that action, you might leave your device in an in-between state from which it won’t be able to recover without wired interaction.


I may had interrupted the first OTA while it got stuck in purple, since I tought a problem was happening.
I never actually used a Photon, and it behaves differently from a Core. Sorry for that.

Well, the “particle update” did the trick. Now its 0.6.2. The SIGNAL started to work too.
So I decided to make an OTA, but it started to flash green.

Then I enabled system threads, and looks like its done.

Thank you guys.


Tthe issue with that (wait for the magenta phase,…) is the fact that we don’t necessarily have visual access to the state of the led during an OTA update. The unit can be remotely located or located inside a black-box and therefore unaccessible to any visual monitoring.
That’s why I am extremely careful when going through this procedure. So far it has been painless, but I know from many years of experience that this is a very sensitive procedure.