[SOLVED]Cant upload programs to my Photon


I cannot upload any new programs to my Photon from the online IDE or the Offline Particle Dev.

This Photon light reports connection to the cloud with its LED and the wifi is connected.

I have no troubles re setting it up with the app however it is always reported as Offline.

The online IDE actually reports success when I upload new programs however at NO point does my Photon LED flash Magenta as the online IDE says it should and I can confirm the program did not in fact upload as when I use the serial monitor on Particle Dev it always outputs the same counting up numbers program!

The problem started after I used the Particle Dev to upload a simple counting app which just outputs to the serial monitor. Basically I cannot overwrite the program for some reason!

The Particle Dev program reports "Build didnt produce binary Error: Command Failed …/…/…/build/target/user/platofrm… when I try to upload to it.

I have just tried the manual firmware install which all went fine but I STILL cant upload a new program no my Photon!


Try Safe Mode, this should allow OTA flashing.

And how does your simple counting code look?
If you got extended delays/loops in there the responsiveness for cloud actions might suffer.

For the Particle Dev issue uploading a screenshot of the whole window sometimes provides clues for us too.

Ok I just gave that a go.

The online IDE reported success but half way through the LED actually went off. I left it off for about 30 seconds and then hit reset.

I have just checked serial output and its still just my numbers counting up program.

Ill try the process again now.



Problem now is Particle Dev still returns an error when I try to upload a program.

“Build didnt produce binary Error: Command Failed …/…/…/build/target/user/platfrom…”

Any ideas ???

All im trying to upload is this

void setup(){

void loop(){
Serial.println(“Hello World”);

The file is called serialtest.ino

Any ideas why the Particle Dev wont upload this? The online IDE has no issues uploading this program.

Yes, plenty - hence this part in my first post.

1 Like

Solved, just put all code in .ino file instead of .cpp.

My rusty coding to blame!