[SOLVED]Can't do the setup via the Android app

I am trying to understand the logic of the Setup via app method, and I am not sure I understand it.
I powered the board via an USB charger, it is blinking blue.
I downloaded the Spark app, and it asked me for the password of my ssid (which is WPA2, password protected)
I entered the password, then had to wait, then it told me that no device was found.

Now my question is, how is this supposed to work? The Spark starts in an AP mode (I can see a Spark SSID). Is the app supposed to disconnect from my main wifi, connect to the spark, send the login details, and then connect back to my main network?

And if so, what exactly is the problem? Why can’t it find it? Is it looking for a specific SSID?

Let’s just start by asking what device you’re trying to use?

It’s the WiFi only board.

I tried the app both from my phoene and from my tablet, same result.

Allright, you said you downloaded the ‘Spark’ app, but it’s the ‘particle’ one you should be looking for. The ‘spark’ one won’t work for the photon, and the Particle one won’t work for the Core.
On iOS they look like this:

Thanks, that worked!

1 Like