[Solved] Another "Can't Connect to WiFi" thread... Please help

So I changed my router and now I can’t connect. My android has the correct password and I’m on the same network and it can’t find the spark core when it searches the network. I resetted the core to the factory defaults and still no luck. I connected via a serial connection with PuTTY and entered in the wifi SSID and password manually and still no luck, just a rapid flashing green LED.

I have WPA2-PSK with AES. Mixed B/N/G mode. Arris router. Updated windows driver.

I also tried connecting with Ubuntu 14.04. I used Screen and the device was mounted at /dev/serial, I think.
the command I typed in was:
screen /dev/serial 9600
the response was:
"screen is terminating /dev/serial no such file or directory"
BUT, this was the only file that popped up and went away in the /dev/ directory every time I plugged the USB in and out.

I’m lost here. Any help would be appreciated.


Try setting b/g only and channel 11 and below.

It’s resolved. I just changed my security to WPA and it was found by the phone. For some reason the WPA2 security wasn’t allowing the core to connect.

I’m guessing the is a flaw in my router. I’ve had problems with my Ubuntu machines connecting to my router.

Then once it was connected to the router with WPA/WPA2, I changed the security back to WPA2-PSK and it connected right away. Very strange.

1 Like

@shittyprogrammer glad to see the problem resolved! I’m going to add the [solved] tag to the thread, unless you have any objections :smile:

Okay. Sounds good. Thanks Will.